Project

General

Profile

Actions

Feature #800

closed

Enable versioning for Documents and Files modules

Added by Jos Yule almost 16 years ago. Updated almost 16 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Documents
Target version:
-
Start date:
2008-03-06
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

I know, the first thing you are going to say is, "just use a VCS [1] repository and hook it into redmine". My use-case for this request is for users of Redmine who are not going to be able to deal with the complexity of a VCS system. I'd like to be able to use a simple web-based file system, like the one currently built into redmine, with a couple of additions. The system doesn't need all the complexities that a full-on VCS requires. Simply keeping a copy of each "upload" of a document/file around and possibly a simple lock/unlock sytem would be amazingly useful. And, hopefully, not overly complex to build.

Another solution, although more complex, is to offer some basic integration with the VCS, via the Repository tab. When you click on an individual file, include a link to "upload" (checkin, commit, whatever) a new version of that file. This, i'd imagine, would be more difficult and fraught with unknowns then including a simple (like, really simple) versioning tool for the builtin documents/files modules.

Thanks,
Jos

[1] Version Control System


Related issues

Is duplicate of Redmine - Feature #991: Document versioningNew2008-04-04

Actions
Actions #1

Updated by Jos Yule almost 16 years ago

This is similar to Feature Request #736.

Actions #2

Updated by Jos Yule almost 16 years ago

  • Status changed from New to Resolved

A better description of what i'd like to see is in ticket #991.

Actions #3

Updated by Thomas Lecavelier almost 16 years ago

  • Status changed from Resolved to Closed

Closed as duplicated of #991 at reporter request.

Actions #4

Updated by Toshi MARUYAMA over 9 years ago

  • Related to deleted (Feature #2555: Possibility for update Documents - version control )
Actions

Also available in: Atom PDF