Project

General

Profile

Actions

Defect #8610

closed

Visiting revisions should try to update revisions before issuing a 404

Added by Dave Abrahams about 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
SCM
Target version:
-
Start date:
2011-06-15
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

I just visited http://mysite.com/projects/xxxx/repository/revisions/a1d98298d2c7bc8d0533b299c418526b8a11d85a and got an immediate 404. Then I visited http://mysite.com/projects/xxxx/repository and there was a long delay before anything was shown, but afterwards, the original link worked.

BTW, the long delay makes me wonder: are we expected to set up a cron job to update revisions? If so, that's not really clear from the docs.


Related issues

Related to Redmine - Feature #8624: revisions should always be automatically fetchedNew2011-06-16

Actions
Actions #1

Updated by ed brown about 13 years ago

is it a real website? if it is and you know the owner contact them or maybe they deleted it too

Actions #2

Updated by Dave Abrahams about 13 years ago

ed brown wrote:

is it a real website? if it is and you know the owner contact them or maybe they deleted it too

Yes, it's a real website but I obfuscated the URL because you can't see the real website anyhow; it's password-protected. I wouldn't expect you to be able to see anything interesting there anyhow because as I said, the link now resolves properly.

Actions #3

Updated by Etienne Massip about 13 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Dave Abrahams wrote:

I just visited http://mysite.com/projects/xxxx/repository/revisions/a1d98298d2c7bc8d0533b299c418526b8a11d85a and got an immediate 404. Then I visited http://mysite.com/projects/xxxx/repository and there was a long delay before anything was shown, but afterwards, the original link worked.

That's the distinction between /revisions and /changes (respectively known as "View revisions" and "View all revisions" links in Repository tab pages) : the first one won't fetch your changes from the SCM (as will /repository if you configure RM to do so) and the second will.

BTW, the long delay makes me wonder: are we expected to set up a cron job to update revisions? If so, that's not really clear from the docs.

If you're accessing your changes in Redmine from outside of Redmine site via direct URL, you might want to add a cron job or a post-update hook (see HowTo setup automatic refresh of repositories in Redmine on commit) to have the revision list up to date, indeed.

Although I'm a little uncomfortable with the actual behavior too, I close the issue as it's the expected behavior.

Actions #4

Updated by Dave Abrahams about 13 years ago

  • Status changed from Closed to Reopened

0. Thanks for the information; that's a big help!
1. is the difference between /revisions and /changes documented somewhere?
2. Do I really have to open a new ticket to flag this as a design/usability bug?

Actions #5

Updated by Etienne Massip almost 13 years ago

  • Status changed from Reopened to Closed

Dave Abrahams wrote:

1. is the difference between /revisions and /changes documented somewhere?

Looked for it quickly in wiki but didn't find anything relevant; as I said, I'm not sure to understand the acutal behavior, so I guess I'm not the right person to write a chapter about it.

2. Do I really have to open a new ticket to flag this as a design/usability bug?

Yes, please, if you want. Mainly because a Feature Request usually presents some new enhancement ideas.

Actions #6

Updated by Dave Abrahams almost 13 years ago

Etienne Massip wrote:

Dave Abrahams wrote:

2. Do I really have to open a new ticket to flag this as a design/usability bug?

Yes, please, if you want. Mainly because a Feature Request usually presents some new enhancement ideas.

Done; see #8624

Actions #7

Updated by Toshi MARUYAMA almost 13 years ago

  • Category set to SCM
Actions

Also available in: Atom PDF