RedmineInstall » History » Version 291

Version 290 (Go MAEDA, 2018-01-20 03:25) → Version 291/306 (Go MAEDA, 2018-06-02 08:05)

h1. Installing Redmine

{{>TOC}}

This is the installation documentation for Redmine 3.0 and higher. You can still read the document for older versions: "1.4.x - 2.6.x":/projects/redmine/wiki/RedmineInstall/263, "1.3.x":/projects/redmine/wiki/RedmineInstall?version=146

h2. Requirements

h3. Operating system

Redmine should run on most Unix, Linux, [[RedmineInstallOSX|macOS]], [[RedmineInstallOSXServer|macOS Server]] and [[RedmineInstall#Notes-on-Windows-installation|Windows]] systems as long as Ruby is available on this platform. See specific installation HowTos [[HowTos|here]].



h3. Ruby interpreter

The required Ruby versions for a given Redmine version is:

|_. Redmine version|_. Supported Ruby versions |_. Rails version used|
|4.0 (upcoming) |ruby 2.2(2.2.2 and later), 2.3, 2.4[1] |Rails 5.1 |
|3.4 |ruby 1.9.3[4], 2.0.0[3], 2.1, 2.2[2], 2.3, 2.4[1] |Rails 4.2 |
|3.3 |ruby 1.9.3[4], 2.0.0[3], 2.1, 2.2[2], 2.3 |Rails 4.2 |
|3.2 |ruby 1.9.3[4], 2.0.0[3], 2.1, 2.2[2] |Rails 4.2 |

%{color: red}Support for Ruby 1.9.3, 2.0 and 2.1 has ended by Ruby community.%
https://www.ruby-lang.org/en/news/2015/02/23/support-for-ruby-1-9-3-has-ended/
https://www.ruby-lang.org/en/news/2016/02/24/support-plan-of-ruby-2-0-0-and-2-1/
https://www.ruby-lang.org/en/news/2017/04/01/support-of-ruby-2-1-has-ended/

*Redmine 3.2 or lower does not support Ruby 2.3*. Redmine 3.3 supports Ruby 2.3.

*Redmine does not support JRuby* because some gems do not support Rails 4.2.
** "activerecord-jdbc-adapter":https://github.com/jruby/activerecord-jdbc-adapter/issues/599
** "loofah":https://github.com/flavorjones/loofah/issues/88

fn1. Ruby 2.4 is supported by r16355 and later.

fn2. MinGW Ruby 2.2 had Nokogiri issue (#19419) and it was fixed by "Nokogiri 1.6.7":https://github.com/sparklemotion/nokogiri/issues/1256#issuecomment-160514102 (2015-11-30).

fn3. At time of writing (3/19/2013), SQL Server support is reported broken with *ruby 2.0.0 under Windows* because of a "database adapter gem incompatibility":https://github.com/rails-sqlserver/tiny_tds/issues/110

fn4. MRI 1.9.3p327 contains "a bug":http://bugs.ruby-lang.org/issues/7374 breaking plugin loading under Windows which 1.9.3p194 or 1.9.3p392 haven't.



h3. Supported database back-ends

* MySQL 5.0 - 5.5

* *MySQL 5.6 or higher* and *MariaDB* have known issues (#19344, #19395, #17460).
* Redmine 4.0.0 does not support MySQL <5.5 (#28504).


* PostgreSQL 8.3 or higher

* make sure your database datestyle is set to ISO (Postgresql default setting). You can set it using: @ALTER DATABASE "redmine_db" SET datestyle="ISO,MDY";@
* some bugs in PostgreSQL 8.4.0 and 8.4.1 affect Redmine behavior (#4259, #4314), they are fixed in PostgreSQL 8.4.2

* Microsoft SQL Server "2012 or higher":https://github.com/rails-sqlserver/activerecord-sqlserver-adapter/blob/v4.2.3/README.md#activerecord-sql-server-adapter-for-sql-server-2012-and-higher

* SQLite 3 (not for multi-user production use!)



h3. Optional components

* SCM binaries (eg. @svn@), for repository browsing (must be available in your PATH). See [[RedmineRepositories]] for SCM compatibility and requirements.
* "ImageMagick":http://www.imagemagick.org/ (to enable Gantt export to PNG image and thumbnails generation).



h2. Redmine Version

It is recommended that the majority of users install the proper point releases of redmine. Redmine currently releases a new version every 6 months, and these releases are considered very usable and stable. It is *not* recommended to install redmine from trunk, unless you are deeply familiar with Ruby on Rails and keep up with the changes - Trunk _does_ break from time-to-time.



h2. Installation procedure

h3. Step 1 - Redmine application

Get the Redmine source code by either downloading a packaged release or checking out the code repository.

See the [[Download|download page]] for details.

h3. Step 2 - Create an empty database and accompanying user

Redmine database user will be named @redmine@ hereafter but it can be changed to anything else.



h4. MySQL

<pre><code class="sql">
CREATE DATABASE redmine CHARACTER SET utf8mb4;
CREATE USER 'redmine'@'localhost' IDENTIFIED BY 'my_password';
GRANT ALL PRIVILEGES ON redmine.* TO 'redmine'@'localhost';
</code></pre>

For versions of MySQL "5.5.2":https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-3.html or lower - use *utf8* instead of "utf8mb4":https://dev.mysql.com/doc/refman/5.5/en/charset-unicode-utf8mb4.html

<pre><code class="sql">
CREATE DATABASE redmine CHARACTER SET utf8;
CREATE USER 'redmine'@'localhost' IDENTIFIED BY 'my_password';
GRANT ALL PRIVILEGES ON redmine.* TO 'redmine'@'localhost';
</code></pre>

For versions of MySQL "5.0.2":https://docs.oracle.com/cd/E17952_01/mysql-5.0-en/grant.html or lower - skip the 'CREATE USER' step and instead:
<pre><code class="sql">
CREATE DATABASE redmine CHARACTER SET utf8;
GRANT ALL PRIVILEGES ON redmine.* TO 'redmine'@'localhost' IDENTIFIED BY 'my_password';
</code></pre>



h4. PostgreSQL

<pre><code class="sql">
CREATE ROLE redmine LOGIN ENCRYPTED PASSWORD 'my_password' NOINHERIT VALID UNTIL 'infinity';
CREATE DATABASE redmine WITH ENCODING='UTF8' OWNER=redmine;
</code></pre>

h4. SQL Server

The database, login and user can be created within ??SQL Server Management Studio?? with a few clicks.

If you prefer the command line option with @SQLCMD@, here's some basic example:

{{collapse(Show SQL,Hide SQL)
<pre><code class="sql">
USE [master]
GO

-- Very basic DB creation
CREATE DATABASE [REDMINE]
GO

-- Creation of a login with SQL Server login/password authentication and no password expiration policy
CREATE LOGIN [REDMINE] WITH PASSWORD=N'redminepassword', DEFAULT_DATABASE=[REDMINE], CHECK_EXPIRATION=OFF, CHECK_POLICY=OFF
GO

-- User creation using previously created login authentication
USE [REDMINE]
GO
CREATE USER [REDMINE] FOR LOGIN [REDMINE]
GO
-- User permissions set via roles
EXEC sp_addrolemember N'db_datareader', N'REDMINE'
GO
EXEC sp_addrolemember N'db_datawriter', N'REDMINE'
GO
</code></pre>
}}

h3. Step 3 - Database connection configuration

Copy @config/database.yml.example@ to @config/database.yml@ and edit this file in order to configure your database settings for "production" environment.

Example for a MySQL database (default port):

<pre><code class="yml">
production:
adapter: mysql2
database: redmine
host: localhost
username: redmine
password: my_password
</code></pre>

If your server is not running on the standard port (3306), use this configuration instead:

<pre><code class="yml">
production:
adapter: mysql2
database: redmine
host: localhost
port: 3307
username: redmine
password: my_password
</code></pre>

Example for a PostgreSQL database (default port):

<pre><code class="yml">
production:
adapter: postgresql
database: <your_database_name>
host: <postgres_host>
username: <postgres_user>
password: <postgres_user_password>
encoding: utf8
schema_search_path: <database_schema> (default - public)
</code></pre>

Example for a SQL Server database (default host @localhost@, default port @1433@):
<pre><code class="yml">
production:
adapter: sqlserver
database: redmine
username: redmine # should match the database user name
password: redminepassword # should match the login password
</code></pre>

h3. Step 4 - Dependencies installation

Redmine uses "Bundler":http://gembundler.com/ to manage gems dependencies.

You need to install Bundler first:

gem install bundler

Then you can install all the gems required by Redmine using the following command:

bundle install --without development test

h4. Optional dependencies

h5. RMagick (allows the use of ImageMagick to manipulate images for PDF and PNG export)

If ImageMagick is not installed on your system, you should skip the installation of the rmagick gem using:

@bundle install --without development test rmagick@

If you have trouble installing @rmagick@ on Windows, refer to [[HowTo_install_rmagick_gem_on_Windows|this HowTo]].

h5. Database adapters

Redmine automatically installs the adapter gems required by your database configuration by reading it from the @config/database.yml@ file (eg. if you configured only a connection using the @mysql2@ adapter, then only the @mysql2@ gem will be installed).

Don't forget to re-run @bundle install --without development test ...@ after adding or removing adapters in the @config/database.yml@ file!

h4. Additional dependencies (@Gemfile.local@)

If you need to load gems that are not required by Redmine core (eg. Puma, fcgi), create a file named @Gemfile.local@ at the root of your redmine directory. It will be loaded automatically when running @bundle install@.

Example:
<pre>
# Gemfile.local
gem 'puma'
</pre>

h3. Step 5 - Session store secret generation

This step generates a random key used by Rails to encode cookies storing session data thus preventing their tampering.
Generating a new secret token invalidates all existing sessions after restart.

<pre>
bundle exec rake generate_secret_token
</pre>

Alternatively, you can store this secret in config/secrets.yml:
http://guides.rubyonrails.org/upgrading_ruby_on_rails.html#config-secrets-yml

h3. Step 6 - Database schema objects creation

Create the database structure, by running the following command under the application root directory:

<pre>
RAILS_ENV=production bundle exec rake db:migrate
</pre>

*Windows syntax:*

<pre>
set RAILS_ENV=production
bundle exec rake db:migrate
</pre>

It will create tables by running all migrations one by one then create the set of the permissions and the application administrator account, named @admin@.

+Ubuntu troubleshooting:+

If you get this error with Ubuntu:
<pre>
Rake aborted!
no such file to load -- net/https
</pre>

Then you need to install @libopenssl-ruby1.8@ just like this: @apt-get install libopenssl-ruby1.8@.

h3. Step 7 - Database default data set

Insert default configuration data in database, by running the following command:

RAILS_ENV=production bundle exec rake redmine:load_default_data

Redmine will prompt you for the data set language that should be loaded; you can also define the @REDMINE_LANG@ environment variable before running the command to a value which will be automatically and silently picked up by the task.

E.g.:

Unices:

RAILS_ENV=production REDMINE_LANG=fr bundle exec rake redmine:load_default_data

Windows:
<pre>
set RAILS_ENV=production
set REDMINE_LANG=fr
bundle exec rake redmine:load_default_data
</pre>



h3. Step 8 - File system permissions

NB: _Windows users can skip this section._

The user account running the application must have write permission on the following subdirectories:

# @files@ (storage of attachments)
# @log@ (application log file @production.log@)
# @tmp@ and @tmp/pdf@ (create these ones if not present, used to generate PDF documents among other things)
# @public/plugin_assets@ (assets of plugins)

E.g., assuming you run the application with a redmine user account:

<pre>
mkdir -p tmp tmp/pdf public/plugin_assets
sudo chown -R redmine:redmine files log tmp public/plugin_assets
sudo chmod -R 755 files log tmp public/plugin_assets
</pre>

Note: If you have files in these directories (e.g. restore files from backup), make sure these files are not executable.

<pre>
sudo find files log tmp public/plugin_assets -type f -exec chmod -x {} +
</pre>



h3. Step 9 - Test the installation

Test the installation by running WEBrick web server:

<pre>
bundle exec rails server webrick -e production
</pre>

Once WEBrick has started, point your browser to http://localhost:3000/. You should now see the application welcome page.

> Note: Webrick is *not* suitable for production use, please only use webrick for testing that the installation up to this point is functional. Use one of the many other guides in this wiki to setup redmine to use either Passenger (aka @mod_rails@), FCGI or a Rack server (Unicorn, Thin, Puma, hellip;) to serve up your redmine.

h3. Step 10 - Logging into the application

Use default administrator account to log in:

* login: admin
* password: admin

You can go to ??Administration?? menu and choose ??Settings?? to modify most of the application settings.



h2. Configuration

Redmine settings are defined in a file named @config/configuration.yml@.

If you need to override default application settings, simply copy @config/configuration.yml.example@ to @config/configuration.yml@ and edit the new file; the file is well commented by itself, so you should have a look at it.

These settings may be defined per Rails environment (@production@/@development@/@test@).

+Important+ : don't forget to restart the application after any change.

h3. Email / SMTP server settings

Email configuration is described in a [[EmailConfiguration|dedicated page]].

h3. SCM settings

This configuration section allows you to:
* override default commands names if the SCM binaries present in the @PATH@ variable doesn't use the standard name (Windows .bat/.cmd names won't work)
* specify the full path to the binary

Examples (with Subversion):

Command name override:

scm_subversion_command: "svn_replacement.exe"

Absolute path:

scm_subversion_command: "C:\Program Files\Subversion\bin\svn.exe"

h3. Attachment storage settings

You can set a path where Redmine attachments will be stored which is different from the default 'files' directory of your Redmine instance using the @attachments_storage_path@ setting.

Examples:

attachments_storage_path: /var/redmine/files

attachments_storage_path: D:/redmine/files

h2. Logging configuration

Redmine defaults to a log level of :info, writing to the @log@ subdirectory. Depending on site usage, this can be a lot of data so to avoid the contents of the logfile growing without bound, consider rotating them, either through a system utility like @logrotate@ or via the @config/additional_environment.rb@ file.

To use the latter, copy @config/additional_environment.rb.example@ to @config/additional_environment.rb@ and add the following lines. Note that the new logger defaults to a high log level and hence has to be explicitly set to @info@.
<pre><code class="ruby">
#Logger.new(PATH,NUM_FILES_TO_ROTATE,FILE_SIZE)
config.logger = Logger.new('/path/to/logfile.log', 2, 1000000)
config.logger.level = Logger::INFO
</code></pre>



h2. Backups

Redmine backups should include:
* data (stored in your redmine database)
* attachments (stored in the @files@ directory of your Redmine install)

Please refer to [[RedmineBackupAndRestore|Backing up and restoring Redmine]] for more details.



h2. Notes on Linux/Unix installation

Be sure to disable security hardenning tools during the installation process if you run into bizarre permission problems. These problems are mostly silent and can be caused by tools like extended ACLs, SELinux, or AppArmor. There tools are mostly used in big companies with a strict security policy, default Linux/Unix distributions settings shouldn't be a problem.



h2. Notes on Windows installation

There is an prebuilt installer of Ruby MRI available from http://rubyinstaller.org.
After installing it, select _Start Command Prompt with Ruby_ in the start menu.

+Specifying the @RAILS_ENV@ environment variable:+

When running command as described in this guide, you have to set the @RAILS_ENV@ environment variable using a separate command.

I.e. commands with the following syntaxes:

<pre>RAILS_ENV=production <any commmand></pre>

<pre><any commmand> RAILS_ENV=production</pre>

have to be turned into 2 subsequent commands:

<pre>set RAILS_ENV=production
<any commmand></pre>

+MySQL gem installation issue:+

You may need to manually install the mysql gem using the following command:

<pre>
gem install mysql
</pre>

And in some case it is required to copy the _libmysql.dll_ file in your ruby/bin directory.
Not all libmysql.dll are ok this seem to works http://instantrails.rubyforge.org/svn/trunk/InstantRails-win/InstantRails/mysql/bin/libmySQL.dll.

*Important note for Win7 and later*
On Win7 and later, @localhost@ is commented out in the hosts file[5] and IPV6 is the default[6]. As the mysql2 gem does no support IPV6 addresses[7], a connection can't be established and you get the error "@Can't connect to MySQL server on 'localhost' (10061)@".
You can confirm this by pinging @localhost@, if ping targets "::1:" IPV6 is being used.

+Workaround:+
Replace @localhost@ with @127.0.0.1@ in database.yml.

fn5. http://serverfault.com/questions/4689/windows-7-localhost-name-resolution-is-handled-within-dns-itself-why

fn6. http://www.victor-ratajczyk.com/post/2012/02/25/mysql-fails-to-resolve-localhost-disable-ipv6-on-windows.aspx

fn7. https://github.com/brianmario/mysql2/issues/279



h2. Alternative to manual installation

Some users may prefer to skip manual installation by using one of the [[Download#Third-party-Redmine-bundles|third-party Redmine bundles]] on the download page.