Security Advisories » History » Version 62

Marius BALTEANU, 2022-02-23 08:23

1 1 Jean-Philippe Lang
h1. Redmine Security Advisories
2 1 Jean-Philippe Lang
3 2 Jean-Philippe Lang
This page lists the security vulnerabilities that were fixed in Redmine releases, starting from 1.3.0. If you think that you've found a security vulnerability, please report it by sending an email to: @security(at)redmine.org@.
4 1 Jean-Philippe Lang
5 35 Jan from Planio www.plan.io
To detect if your own Redmine is subject to any of these vulnerabilties, you can use Planio's "Redmine Security Scanner":https://plan.io/redmine-security-scanner/.
6 35 Jan from Planio www.plan.io
7 21 Jan from Planio www.plan.io
|_. Severity|_. Details|_.External references|_. Affected versions|_. Fixed versions|
8 62 Marius BALTEANU
|{background-color:#ff8}. Moderate |Ruby on Rails vulnerability ("announcement":https://rubyonrails.org/2022/2/11/Rails-7-0-2-2-6-1-4-6-6-0-4-6-and-5-2-6-2-have-been-released)|"CVE-2022-23633":https://discuss.rubyonrails.org/t/cve-2022-23633-possible-exposure-of-information-vulnerability-in-action-pack/80016|All Redmine 4.* versions|version:4.2.4 and version:4.1.6|
9 60 Holger Just
|{background-color:#ff8}. Moderate|Activities index view is leaking usernames (#35789)|"CVE-2021-42326":https://nvd.nist.gov/vuln/detail/CVE-2021-42326|All prior releases|version:4.2.3 and version:4.1.5|
10 58 Holger Just
|{background-color:#ffc}. Low|User sessions not reset after activation of two-factor authentication (#35417)|"CVE-2021-37156":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-37156|version:4.2.0 and version:4.2.1|version:4.2.2|
11 56 Holger Just
|{background-color:#fb8}. High |Ruby on Rails vulnerabilities ("announcement":https://weblog.rubyonrails.org/2021/5/5/Rails-versions-6-1-3-2-6-0-3-7-5-2-4-6-and-5-2-6-have-been-released/)|"CVE-2021-22885":https://discuss.rubyonrails.org/t/cve-2021-22885-possible-information-disclosure-unintended-method-execution-in-action-pack/77868, "CVE-2021-22904":https://discuss.rubyonrails.org/t/cve-2021-22904-possible-dos-vulnerability-in-action-controller-token-authentication/77869|All prior releases|version:4.2.2 and version:4.1.4|
12 52 Holger Just
|{background-color:#ffc}. Low|Mail handler bypasses add_issue_notes permission (#35045)|"CVE-2021-31864":https://nvd.nist.gov/vuln/detail/CVE-2021-31864|All prior releases since version:3.3.0|version:4.2.1, version:4.1.3 and version:4.0.9|
13 52 Holger Just
|{background-color:#ff8}. Moderate|Allowed filename extensions of attachments can be circumvented (#34367)|"CVE-2021-31865":https://nvd.nist.gov/vuln/detail/CVE-2021-31865|All prior releases|version:4.2.1, version:4.1.3 and version:4.0.9|
14 52 Holger Just
|{background-color:#f88}. Critical|Arbitrary file read in Git adapter (#35085)|"CVE-2021-31863":https://nvd.nist.gov/vuln/detail/CVE-2021-31863|All prior releases|version:4.2.1, version:4.1.3 and version:"4.0.9"|
15 52 Holger Just
|{background-color:#ff8}. Moderate|SysController and MailHandlerController are vulnerable to timing attack (#34950)|"CVE-2021-31866":https://nvd.nist.gov/vuln/detail/CVE-2021-31866|All prior releases to version:4.2.0|version:4.2.0, version:4.1.3 and version:"4.0.9"|
16 48 Holger Just
|{background-color:#fb8}. High|Inline issue auto complete doesn't sanitize HTML tags (#33846)|"CVE-2021-29274":https://nvd.nist.gov/vuln/detail/CVE-2021-29274|version:4.1.0 and version:4.1.1 |version:4.1.2 and version:4.0.8|
17 51 Holger Just
|{background-color:#ff8}. Moderate|Names of private projects are leaked by issue journal details that contain project_id changes(#33360)|"CVE-2021-30163":https://nvd.nist.gov/vuln/detail/CVE-2021-30163|All prior releases|version:4.1.2 and version:4.0.8|
18 51 Holger Just
|{background-color:#fb8}. High|Issues API bypasses add_issue_notes permission (#33689)|"CVE-2021-30164":https://nvd.nist.gov/vuln/detail/CVE-2021-30164|All prior releases since version:3.3.0|version:4.1.2 and version:4.0.8|
19 46 Marius BALTEANU
|{background-color:#fb8}. High |Ruby on Rails vulnerabilities ("rails 5.2.4.3":https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released/, "rails 5.2.4.5":https://weblog.rubyonrails.org/2021/2/10/Rails-5-2-4-5-6-0-3-5-and-6-1-2-1-have-been-released/)|"CVE-2020-8162":https://nvd.nist.gov/vuln/detail/CVE-2020-8162, "CVE-2020-8164":https://nvd.nist.gov/vuln/detail/CVE-2020-8164, "CVE-2020-8165":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8165, "CVE-2020-8166":https://nvd.nist.gov/vuln/detail/CVE-2020-8166, "CVE-2020-8167":https://nvd.nist.gov/vuln/detail/CVE-2020-8167, "CVE-2021-22880":https://nvd.nist.gov/vuln/detail/CVE-2021-22880, "CVE-2021-22881":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-22881|All prior releases|version:4.1.2 and version:4.0.8|
20 51 Holger Just
|{background-color:#ff8}. Moderate|XSS vulnerability due to missing back_url validation (#32850)|"CVE-2020-36306":https://nvd.nist.gov/vuln/detail/CVE-2020-36306|All prior releases|version:4.1.1 and version:4.0.7|
21 51 Holger Just
|{background-color:#fb8}. High|Persistent XSS vulnerabilities in textile inline links (#32934)|"CVE-2020-36307":https://nvd.nist.gov/vuln/detail/CVE-2020-36307|All prior releases|version:4.1.1 and version:4.0.7|
22 51 Holger Just
|{background-color:#ff8}. Moderate|Time entries CSV export may disclose subjects of issues that are not visible|"CVE-2020-36308":https://nvd.nist.gov/vuln/detail/CVE-2020-36308|All prior releases|version:4.1.1 and version:4.0.7|
23 51 Holger Just
|{background-color:#ff8}. Moderate|Improper markup sanitization in Textile formatting (#25742)|"CVE-2019-25026":https://nvd.nist.gov/vuln/detail/CVE-2019-25026|All prior releases|version:4.0.6 and version:3.4.13|
24 42 Jean-Philippe Lang
|{background-color:#f88}. Critical|SQL injection|"CVE-2019-18890":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18890|Redmine <= 3.3.9|version:3.3.10|
25 41 Holger Just
|{background-color:#fb8}. High|Persistent XSS in textile formatting|"CVE-2019-17427":https://nvd.nist.gov/vuln/detail/CVE-2019-17427|All prior releases|version:3.4.11 and version:4.0.4|
26 39 Jean-Philippe Lang
|{background-color:#f88}. Critical|Ruby on Rails vulnerabilities ("announcement":https://weblog.rubyonrails.org/2019/3/13/Rails-4-2-5-1-5-1-6-2-have-been-released/)|"CVE-2019-5418":https://github.com/mpgn/CVE-2019-5418, "CVE-2019-5419":https://nvd.nist.gov/vuln/detail/CVE-2019-5419, "CVE-2019-5420":https://nvd.nist.gov/vuln/detail/CVE-2019-5420|All prior releases|version:3.4.10 and version:4.0.3|
27 38 Go MAEDA
|{background-color:#fb8}. High|Remote command execution through mercurial adapter|"CVE-2017-18026":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-18026|All prior releases|version:3.2.9, version:3.3.6 and version:3.4.4|
28 37 Jean-Philippe Lang
|{background-color:#fb8}. High|Multiple XSS vulnerabilities (#27186)|"CVE-2017-15568":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15568, "CVE-2017-15569":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15569, "CVE-2017-15570":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15570, "CVE-2017-15571":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15571|All prior releases|version:3.2.8, version:3.3.5 and version:3.4.3|
29 34 Mischa The Evil
|{background-color:#ffc}. Low|Email reminders reveal information about inaccessible issues (#25713)|"CVE-2017-16804":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16804|All prior releases|version:3.2.7, version:3.3.4 and version:3.4.0|
30 32 Mischa The Evil
|{background-color:#ff8}. Moderate|Improper markup sanitization in wiki content (#25503)|"CVE-2017-15573":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15573|All prior releases|version:3.2.6 and version:3.3.3|
31 32 Mischa The Evil
|{background-color:#ff8}. Moderate|Use redirect on /account/lost_password to prevent password reset tokens in referers (#24416)|"CVE-2017-15572":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15572|All prior releases|version:3.2.6 and version:3.3.3|
32 32 Mischa The Evil
|{background-color:#ff8}. Moderate|Redmine.pm doesn't check that the repository module is enabled on project (#24307)|"CVE-2017-15575":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15575|All prior releases|version:3.2.6 and version:3.3.3|
33 32 Mischa The Evil
|{background-color:#fb8}. High|Stored XSS with SVG attachments (#24199)|"CVE-2017-15574":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15574|All prior releases|version:3.2.6 and version:3.3.3|
34 32 Mischa The Evil
|{background-color:#ff8}. Moderate|Information leak when rendering Time Entry on activity view (#23803)|"CVE-2017-15576":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15576|All prior releases|version:3.2.6 and version:3.3.3|
35 32 Mischa The Evil
|{background-color:#ff8}. Moderate|Information leak when rendering Wiki links (#23793)|"CVE-2017-15577":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15577|All prior releases|version:3.2.6 and version:3.3.3|
36 32 Mischa The Evil
|{background-color:#fb8}. High|Persistent XSS vulnerabilities in text formatting (Textile and Markdown) and project homepage|"CVE-2016-10515":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10515|All prior releases|version:3.2.3|
37 26 Jean-Philippe Lang
|{background-color:#f88}. Critical|ImageMagick vulnerabilities|"CVE-2016-3714":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3714|All prior releases since 2.1.0|version:3.1.5 and version:3.2.2|
38 25 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Data disclosure in atom feed|"CVE-2015-8537":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8537|All prior releases|version:2.6.9, version:3.0.7 and version:3.1.3|
39 23 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Potential changeset message disclosure in issues API|"CVE-2015-8473":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8473|All prior releases|version:2.6.8, version:3.0.6 and version:3.1.2|
40 24 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Data disclosure on the time logging form|"CVE-2015-8346":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8346|All prior releases|version:2.6.8, version:3.0.6 and version:3.1.2|
41 22 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Open Redirect vulnerability|"CVE-2015-8474":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8474|2.5.1 to 2.6.6, 3.0.0 to 3.0.4 and 3.1.0|version:2.6.7, version:3.0.5 and version:3.1.1|
42 22 Jan from Planio www.plan.io
|{background-color:#ffc}. Low|Potential XSS vulnerability when rendering some flash messages|"CVE-2015-8477":https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8477|All prior releases|version:2.6.2 and version:3.0.0|
43 21 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Potential data leak (project names) in the invalid form authenticity token error screen||All prior releases|version:2.4.6 and version:2.5.2|
44 21 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Open Redirect vulnerability|"JVN#93004610":https://jvn.jp/en/jp/JVN93004610/index.html, "CVE-2014-1985":http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-1985|All prior releases|version:2.4.5 and version:2.5.1|
45 21 Jan from Planio www.plan.io
|{background-color:#f88}. Critical|Ruby on Rails vulnerability ("announcement":http://weblog.rubyonrails.org/2013/3/18/SEC-ANN-Rails-3-2-13-3-1-12-and-2-3-18-have-been-released/)||All releases prior to 2.2.4|version:2.2.4, version:2.3.0|
46 21 Jan from Planio www.plan.io
|{background-color:#f88}. Critical|Ruby on Rails vulnerability ("announcement":http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/)||All releases prior to 2.2.3|version:2.2.3|
47 21 Jan from Planio www.plan.io
|{background-color:#f88}. Critical|Ruby on Rails vulnerability ("announcement":https://groups.google.com/forum/?fromgroups=#!topic/rubyonrails-security/1h2DR63ViGo)||All releases prior to 2.2.1 and 2.1.6|"Fix for 1.4.7":/news/78|
48 21 Jan from Planio www.plan.io
|{background-color:#f88}. Critical|Ruby on Rails vulnerability ("announcement":https://groups.google.com/forum/#!msg/rubyonrails-security/c7jT-EeN9eI/L0u4e87zYGMJ)||All releases prior to 2.2.1 and 2.1.6|version:1.4.7|
49 21 Jan from Planio www.plan.io
|{background-color:#f88}. Critical|Ruby on Rails vulnerability ("announcement":http://weblog.rubyonrails.org/2013/1/8/Rails-3-2-11-3-1-10-3-0-19-and-2-3-15-have-been-released/)||All prior releases| version:2.2.1, version:2.1.6, version:1.4.6|
50 21 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|XSS vulnerability||2.1.0 and 2.1.1|version:2.1.2|
51 21 Jan from Planio www.plan.io
|{background-color:#fb8}. High|Persistent XSS vulnerability|"JVN#93406632":http://jvn.jp/en/jp/JVN93406632/, "CVE-2012-0327":http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-0327|All prior releases|version:1.3.2|
52 21 Jan from Planio www.plan.io
|{background-color:#ff8}. Moderate|Mass-assignemnt vulnerability that would allow an attacker to bypass part of the security checks||All prior releases|version:1.3.2|
53 21 Jan from Planio www.plan.io
|{background-color:#fb8}. High|Vulnerability that would allow an attacker to bypass the CSRF protection||All prior releases|version:1.3.0|