Can't install redmine 1.4 gem install bundle

Added by Craig Efrein over 2 years ago

Whenever I run the command

rake config/initializers/session_store.rb

I get this message

Some gems may need to be installed or updated.
Please run `bundle install --without development test`.

So I run bundle install --without development test and get this message

[root@redmine-clone redmine]# bundle install --without development test
Fetching gem metadata from http://rubygems.org/.......
Using rake (0.9.2.2) 
Using activesupport (2.3.14) 
Using rack (1.1.3) 
Using actionpack (2.3.14) 
Using actionmailer (2.3.14) 
Using activerecord (2.3.14) 
Using activeresource (2.3.14) 
Using coderay (1.0.6) 
Using fastercsv (1.5.4) 
Using i18n (0.4.2) 
Using mysql (2.8.1) 
Using net-ldap (0.3.1) 
Installing pg (0.13.2) with native extensions 
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb 
checking for pg_config... no
No pg_config... trying anyway. If building fails, please try again with
 --with-pg-config=/path/to/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

I don't use postgresql for redmine nor do I plan to. Can anyone help?

Replies (6)

RE: Can't install redmine 1.4 gem install bundle - Added by Alex A over 2 years ago

U must edit redmine Gemfile to remove pg, sqlite references.

RE: Can't install redmine 1.4 gem install bundle - Added by Craig Efrein over 2 years ago

Thank you, at least that got me past the postgresql problem. Now it's saying that I need rmagick 2.13.1. So I downloaded the latest

wget http://image_magick.veidrodis.com/image_magick/ImageMagick-6.3.2-9.tar.gz
tar -zxvf ImageMagick-6.3.2-9.tar.gz
cd ImageMagick-6.3.2
./configure --prefix=/usr/local --with-bzlib=yes --with-fontconfig=yes --with-freetype=yes --with-gslib=yes --with-gvc=yes --with-jpeg=yes --with-jp2=yes --with-png=yes --with-tiff=yes
make && make install

The make and make install go okay, but I get nasty errors when I install the 2.13.11 gem

gem install rmagick -v=2.13.1 --no-rdoc --no-ri

======================================================================
Mon 23Apr12 15:46:52
This installation of RMagick 2.13.1 is configured for
Ruby 1.8.7 (x86_64-linux) and ImageMagick 6.7.6 Q16 
======================================================================

make
gcc -I. -I. -I/usr/local/lib/ruby/1.8/x86_64-linux -I. -DRUBY_EXTCONF_H=\"extconf.h\"   -fPIC    -c rmagick.c
gcc -I. -I. -I/usr/local/lib/ruby/1.8/x86_64-linux -I. -DRUBY_EXTCONF_H=\"extconf.h\"   -fPIC    -c rmmontage.c
gcc -I. -I. -I/usr/local/lib/ruby/1.8/x86_64-linux -I. -DRUBY_EXTCONF_H=\"extconf.h\"   -fPIC    -c rmdraw.c
rmdraw.c: In function ‘Draw_composite’:
rmdraw.c:1135: erreur: ‘ChangeMaskCompositeOp’ undeclared (first use in this function)
rmdraw.c:1135: erreur: (Each undeclared identifier is reported only once
rmdraw.c:1135: erreur: for each function it appears in.)
rmdraw.c:1185: erreur: ‘DivideCompositeOp’ undeclared (first use in this function)
rmdraw.c:1237: erreur: ‘LinearLightCompositeOp’ undeclared (first use in this function)
rmdraw.c: In function ‘get_dummy_tm_img’:
rmdraw.c:1878: attention : assignment makes pointer from integer without a cast
make: *** [rmdraw.o] Erreur 1

RE: Can't install redmine 1.4 gem install bundle - Added by Ivan Cenov over 2 years ago

AFAIK, redmine does not use rmagick, so you may execute

bundle install --without development test rmagick

fcgi error - Added by Craig Efrein over 2 years ago

Thanks,

I actually just updated to Imagik 6.4.9 which worked fine.

Now I'm getting this error RAILS_ENV=production /usr/local/bin/ruby /opt/redmine/public/dispatch.fcgi

/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require': no such file to load -- fcgi (MissingSourceFile)
    from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
    from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/fcgi_handler.rb:1
    from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
    from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
    from /opt/redmine/public/dispatch.fcgi:22

RE: Can't install redmine 1.4 gem install bundle - Added by Stefan Lindecke over 2 years ago

Add this to the top of the Gemfile

gem "fcgi", "0.8.8" 

It must look like this :

source :rubygems

gem "fcgi", "0.8.8" 
gem "rails", "2.3.14" 

Than, i was able to run the bundler with this :

bundle install --without test development rmagick postgresql

Internal Error - Added by Craig Efrein over 2 years ago

Thank you for the reply. I can now see the Redmine Home Page, Redmine is connecting successfully to our ldap server but now I'm getting this

Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

When I open up the production.log in /opt/redmine/log it doesn't say anything. Nothing either in the lighttpdlog.

(1-6/6)