Problem with last revision (2218) from trunk

Added by Ludovic Alcala almost 9 years ago

Hello,
i upgraded my system to the last version of trunk and i have :

  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    syntax error on line 698, col 82: `'
    /usr/lib/ruby/1.8/yaml.rb:133:in `load'
    /usr/lib/ruby/1.8/yaml.rb:133:in `load'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:178:in `load_localiz ed_strings'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:175:in `each'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:175:in `load_localiz ed_strings'
    /var/www/html/redmine/config/initializers/30-redmine.rb:4
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:35 5:in `new_constants_in'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:484:in `load_application_i nitializers'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:483:in `each'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:483:in `load_application_i nitializers'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:149:in `process'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:97:in `send'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:97:in `run'
    /var/www/html/redmine/config/environment.rb:18
    /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:51 0:in `require'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:35 5:in `new_constants_in'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:51 0:in `require'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/tasks/misc.rake:3
    /usr/lib/ruby/1.8/rake.rb:546:in `call'
    /usr/lib/ruby/1.8/rake.rb:546:in `execute'
    /usr/lib/ruby/1.8/rake.rb:541:in `each'
    /usr/lib/ruby/1.8/rake.rb:541:in `execute'
    /usr/lib/ruby/1.8/rake.rb:508:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
    /usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:518:in `invoke_prerequisites'
    /usr/lib/ruby/1.8/rake.rb:1183:in `each'
    /usr/lib/ruby/1.8/rake.rb:1183:in `send'
    /usr/lib/ruby/1.8/rake.rb:1183:in `each'
    /usr/lib/ruby/1.8/rake.rb:515:in `invoke_prerequisites'
    /usr/lib/ruby/1.8/rake.rb:507:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
    /usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:494:in `invoke'
    /usr/lib/ruby/1.8/rake.rb:1931:in `invoke_task'
    /usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1909:in `each'
    /usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/1.8/rake.rb:1903:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1881:in `run'
    /usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/1.8/rake.rb:1878:in `run'
    /usr/bin/rake:28
    (in /var/www/html/redmine)
  • Invoke db:migrate_plugins (first_time)
  • Invoke environment (first_time)
  • Execute environment
    rake aborted!
    syntax error on line 698, col 82: `n_adapters/mysql_adapter.rb'
    /usr/lib/ruby/1.8/yaml.rb:133:in `load'
    /usr/lib/ruby/1.8/yaml.rb:133:in `load'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:178:in `load_localiz ed_strings'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:175:in `each'
    /var/www/html/redmine/vendor/plugins/gloc-1.1.0/lib/gloc.rb:175:in `load_localiz ed_strings'
    /var/www/html/redmine/config/initializers/30-redmine.rb:4
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:35 5:in `new_constants_in'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:50 3:in `load'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:484:in `load_application_i nitializers'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:483:in `each'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:483:in `load_application_i nitializers'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:149:in `process'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:97:in `send'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/initializer.rb:97:in `run'
    /var/www/html/redmine/config/environment.rb:18
    /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
    /usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:51 0:in `require'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:35 5:in `new_constants_in'
    /var/lib/gems/1.8/gems/activesupport-2.1.2/lib/active_support/dependencies.rb:51 0:in `require'
    /var/lib/gems/1.8/gems/rails-2.1.2/lib/tasks/misc.rake:3
    /usr/lib/ruby/1.8/rake.rb:546:in `call'
    /usr/lib/ruby/1.8/rake.rb:546:in `execute'
    /usr/lib/ruby/1.8/rake.rb:541:in `each'
    /usr/lib/ruby/1.8/rake.rb:541:in `execute'
    /usr/lib/ruby/1.8/rake.rb:508:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
    /usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:518:in `invoke_prerequisites'
    /usr/lib/ruby/1.8/rake.rb:1183:in `each'
    /usr/lib/ruby/1.8/rake.rb:1183:in `send'
    /usr/lib/ruby/1.8/rake.rb:1183:in `each'
    /usr/lib/ruby/1.8/rake.rb:515:in `invoke_prerequisites'
    /usr/lib/ruby/1.8/rake.rb:507:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:501:in `synchronize'
    /usr/lib/ruby/1.8/rake.rb:501:in `invoke_with_call_chain'
    /usr/lib/ruby/1.8/rake.rb:494:in `invoke'
    /usr/lib/ruby/1.8/rake.rb:1931:in `invoke_task'
    /usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1909:in `each'
    /usr/lib/ruby/1.8/rake.rb:1909:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/1.8/rake.rb:1903:in `top_level'
    /usr/lib/ruby/1.8/rake.rb:1881:in `run'
    /usr/lib/ruby/1.8/rake.rb:1948:in `standard_exception_handling'
    /usr/lib/ruby/1.8/rake.rb:1878:in `run'
    /usr/bin/rake:28

when i migrate + migrate_plugins.

versions :
actionmailer (2.2.2, 2.1.2)
actionpack (2.2.2, 2.1.2)
activerecord (2.2.2, 2.1.2)
activeresource (2.2.2, 2.1.2)
activesupport (2.2.2, 2.1.2)
fastthread (1.0.1)
mysql (2.7)
passenger (2.0.6)
rack (0.4.0)
rails (2.2.2, 2.1.2)
rake (0.8.3)
tzinfo (0.3.12)

Replies (4)

RE: Problem with last revision (2218) from trunk - Added by Ludovic Alcala almost 9 years ago

the cause is a bad yml language script.

RE: Problem with last revision (2218) from trunk - Added by Ludovic Alcala almost 9 years ago

here the problem :

trunk/lang/sv.yml (revision 2218)
696 696
697 697

enumeration_issue_priorities: Ärendeprioriteter

698 698

enumeration_doc_categories: Dokumentkategorier

699

enumeration_activities: Aktiviteter (tidsuppföljning)

699

enumeration_activities: Aktiviteter (tidsuppföljning)text_plugin_assets_writable: Plugin assets directory writable

RE: Problem with last revision (2218) from trunk - Added by Ludovic Alcala almost 9 years ago

problem with style :( :

here the revision, file sv.yml.
http://www.redmine.org/repositories/diff/redmine?rev=2218

miss a carriage return.

(1-4/4)