[Solved] mongrel issues `require': no such file to load -- dispatcher (LoadError)

Added by brain90 astalavista about 4 years ago

Hello all, i have installed redmines v2.3.3, it run successfully with webrick. Now i want to run it over mongrel_rails.
This what i do :

mongrel_rails start -P /var/www/redmine233/log/redmine.pid -d --environment=production -p 6789

Here the message from the log

/var/lib/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require': no such file to load -- dispatcher (LoadError)
        from /var/lib/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
        from /var/lib/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:236:in `load_dependency'
        from /var/lib/gems/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:148:in `rails'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:113:in `cloaker_'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `call'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `listener'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:99:in `cloaker_'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `call'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `initialize'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `new'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `run'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:in `run'
        from /var/lib/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
        from /var/lib/gems/1.8/bin/mongrel_rails:19:in `load'
        from /var/lib/gems/1.8/bin/mongrel_rails:19

Thanks in advance for any helps.

Replies (4)

RE: [Help] mongrel issues `require': no such file to load -- dispatcher (LoadError) - Added by Ivan Cenov about 4 years ago

When I moved from Redmine 1.4.x to Redmine 2.0 I had to switch from mongrel to thin server (puma server is suitable too). I am running Redmine on Windows box though.

RE: [Help] mongrel issues `require': no such file to load -- dispatcher (LoadError) - Added by brain90 astalavista about 4 years ago

Hello Ivan and Jan, Thanks for reply. Yes. In the end i'm using thin to run it up. This what i do :

sudo apt-get install thin
sudo /etc/init.d/thin1.8 start

cd to redmine directory and run this command:
thin -p 7777 -l log/thin.log -P log/redmine233.pid -e production start

Last, browse it from the address at the given port. ex: http://yourip:7777
  • MyBox
    - Ubuntu 10.10
    - Redmine v2.3.3

RE: [Solved] mongrel issues `require': no such file to load -- dispatcher (LoadError) - Added by Ivan Cenov about 4 years ago

I hope it's successful with thin...

You may try to setup Apache proxy balancer in front of thin. This brings benefits, one of them is that people may access Redmine on port 80; Also you may start several instances of thin and this way minimize response time of the system.

(1-4/4)