"The page you were looking for doesn't exist."

Added by John McBade almost 10 years ago

I believe I have gotten all the way installing Redmine on a Hostgator shared hosting server.

I have all the DB:Migrate and the sample "Production" data installed. The app shows running. Looking at the DB using phpMyAdmin, tables are there with data.

I have all the steps done as far as I can tell but when I use the URL rewrite to go to the location of the app, I get the error: "The page you were looking for doesn't exist." That I see is being generated by Redmine.

Thank you for your assistance,

-John

Replies (2)

RE: "The page you were looking for doesn't exist." - Added by Marek Kreft almost 10 years ago

HI

"I have all the steps done" .. that doesn't give to much information.. but did you

  rake config/initializers/session_store.rb 
???

RE: "The page you were looking for doesn't exist." - Added by John McBade almost 10 years ago

Thanks for the reply.... I'm stumpted so far.

I have done this step and still not giving me the openg page of the app.

It may be that Hostgator is running Rails 2.3.3 I have come to find out. I saw this article here: http://www.redmine.org/boards/2/topics/5148#message-5149 and I don't have that line with "add_frozen_gem_path" in my file. I was able to initialize all the DBs fine using ssh.

I have the production.log that seems to identify the failure and I have attached it. This is now dup info as I have posted this issue in relation to: Defect #3597 but since you have more experience with this app and Rails than I, I want to extend the info to you as well in case you might have a work around.

I hope that is ok.

Thanks in advance with hopes of getting this working. This seems so much a better app then anything else out there I have tried.

-John

production.log (2.77 KB)

(1-2/2)