RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk

Added by Nanda P almost 8 years ago

  • I updated RedMine server with the latest trunk version & tried to rake, getting the following error..
C:\Program Files\redmine\current>rake db:migrate_plugins --trace RAILS_ENV=produ
ction
(in C:/Program Files/redmine/current)
** Invoke db:migrate_plugins (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
RubyGem version error: rack(1.0.0 not ~> 1.0.1)
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:271:in `require_frameworks'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:134:in `process'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `send'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in `run'
C:/Program Files/redmine/current/config/environment.rb:20
C:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
C:/Program Files/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in `new_constants_in'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in `require'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/misc.rake:4
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
C:/Program Files/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
C:/Program Files/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Program Files/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Program Files/Ruby/bin/rake:19:in `load'
C:/Program Files/Ruby/bin/rake:19

C:\Program Files\redmine\current>

Note: I upgraded "gem install -v=2.3.5 rails" & "gem install rake"

Thanks,
Nanda

Replies (10)

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Mischa The Evil almost 8 years ago

Nanda Palaniswamy wrote:

  • I updated RedMine server with the latest trunk version & tried to rake, getting the following error..

[...]

Note: I upgraded "gem install -v=2.3.5 rails" & "gem install rake"

Somehow it seems Rails 2.3.5, which is now used by Redmine trunk, requires Rack 1.0.1. So you should be fine after updating it with gem update rack.

Btw: the installation of Rails 2.3.5 should be done using gem install rails -v=2.3.5. Rake is most-likely already available so it shouldn't be needed to install it...

 
Regards,

Mischa.

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Nanda P almost 8 years ago

Thanks Mischa, It worked! :)

C:\Program Files\redmine\current>gem install rails -v=2.3.5
Successfully installed rails-2.3.5
1 gem installed
Installing ri documentation for rails-2.3.5...
Installing RDoc documentation for rails-2.3.5...

C:\Program Files\redmine\current>gem update rack
Updating installed gems
Updating rack
Successfully installed rack-1.0.1
Gems updated: rack
Installing ri documentation for rack-1.0.1...
Installing RDoc documentation for rack-1.0.1...

C:\Program Files\redmine\current>rake db:migrate --trace RAILS_ENV=production
(in C:/Program Files/redmine/current)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate
** Invoke db:schema:dump (first_time)
** Invoke environment
** Execute db:schema:dump

C:\Program Files\redmine\current>

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Billy T almost 8 years ago

It helped me too, since

RubyGem version error: rack(1.0.0 not ~> 1.0.1)

didnot work.

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Billy T almost 8 years ago

sorry,
I was trying to say

RAILS_ENV=production rake db:migrate

didn't work.

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Billy T almost 8 years ago

I found only rack 1.0.1 works for rails 2.3.5.
so install rack with version

gem install rack -v=1.0.1

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Anonymous almost 8 years ago

I get the same problem on FreeBSD with rack 1.1.0 and the latest ports tree. How are distributions supposed to work around this? I'm not sure if its a good idea to recommend all users to manually install an older rack version.

vs1# rake db:migrate RAILS_ENV=production
(in /usr/local/www/redmine)
rake aborted!
RubyGem version error: rack(1.1.0 not ~> 1.0.1)

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Galaxy King over 7 years ago

I'm still getting the same issue. I have 1.1.0 and 1.0.1 both installed but i'm getting the error:

rake aborted!
RubyGem version error: rack(1.1.0 not ~> 1.0.1)

I downloaded the latest version 0.9.2.

Any advise?

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by Sathvik N over 7 years ago

Thanks guys...
Problem resolved...

1.1.0 did not work for me
so i used 1.0.1 instead and it works fine...

Changes I did

gem install rails -v=2.3.5
gem update rack -v=1.0.1

Why doesnt it work with 1.1.0??

RE: RubyGem version error: rack(1.0.0 not ~> 1.0.1) - Error with latest trunk - Added by percy li over 7 years ago

The current stable (Redmine 0.9.2) seems not work with rack 1.1.0.
Only rack 1.0.1 works.

(1-10/10)