Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError

Added by ... cole over 9 years ago

I need some assistance tracking this problem down.

Fresh installation redmine 0.9.3 .

enter an issue, get 500 Internal Server Error. However the issue is inserted into the DB. Likewise get 500 when trying to view the issue. It's a function of displaying the issue.

snippet of production log attached.

Also, get the same result trying to 'show' an issue.

production.log (4.23 KB)

Replies (11)

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by Felix Schäfer over 9 years ago

It seems most errors of this type are due to plugins… Any plugin installed?

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by ... cole over 9 years ago

no plugins installed. thanks for your reply. any other ideas?

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by ... cole over 9 years ago

Fresh installation of bitnami redmine 0.9.3 stack:

http://bitnami.org/stack/redmine

on CentOS 5.4 generic EC2 image:
uname: Linux 2.6.21.7-2.fc8xen #1 SMP Fri Feb 15 12:39:36 EST 2008 i686 i686 i386 GNU/Linux

BitNami Redmine Stack ships with the following software versions:

- Redmine 0.9.3
- Apache 2.2.14
- ImageMagick 6.5.8
- MySQL 5.1.30
- Subversion 1.6.6
- Ruby 1.8.7-2010.01
- Rails 2.3.5
- RubyGems 1.3.5

all defaults on the installation. i go straight to New Issue, fill out the required fields, click the [Create] button, and get directed to the Internal Server Error page.

Now, the issue in fact gets created, i get an email notification, etc. I then go to view existing issues, and my new issue i just created is listed, so i click the link to view the issue details and again i am directed to the Internal Server Error page.

thanks again. I used redmine on a project about 2 years ago and loved it. now i'm trying to set it up for this new project. I really want this to work.

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by ... cole over 9 years ago

ok, i downloaded 0.9.3 stable and installed it in place of the redmine0.9.3 kit bundled with the bitnomi redmine stack. then i had to weave in some hackery so the bitnami superstructure could manage (start,stop,etc) the new redmine install:

- from the 'broken' redmine: copied rails standard directory "config"
- from the 'broken' redmine: copied bitnami extra directories:
1. scripts
2. conf

and my "Show Issue" problem is solved.

I have no idea what other trouble lurks.

comments??

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by Felix Schäfer over 9 years ago

Not sure what version bitnami ships (if stock or modified), so I can't say for sure.

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by ... cole over 9 years ago

NOPE. I lied. sometimes it works, sometimes not.

mongrels are hanging. randomly.

any one?

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by Felix Schäfer over 9 years ago

Not sure if this the root of the problem, but the mysql gem doesn't support MySQL 5.1 yet, as far I know.

RE: Can't Show Issue (500 Internal Server Error) - ActionView::TemplateError - Added by ... cole over 9 years ago

interesting, Felix. Thanks for your input. hmm. maybe. MySQL 5.1 came bundled in the bitnomi stack. I wonder if that is an oversight?

Replacing a component (like MySQL) in a bitnomi stack installation is not practical...

I tried to hack the bitnomi stack installation to use my system's version of ruby, rather than its embedded version. not a trivial task.

Anyhow. I've spent more time trying to use this prefab stack than it's worth. I'm now onto installing each component from scratch, like the good old days.

(1-11/11)