gmail noreply problem

Added by max müller about 9 years ago

hello,

we are using one google-apps account to send emails for redmine.
this works good. the problem is that we dont want the recipient
to see the real mailaddress and also be able to answer to that address.

so the mail-sender option under mail-administration was working
with the localmailserver but noct with the external googleapps-account.

is there a option that can be set in the email.yml?
any help how to get a noreply address as sender would be great.

thx best m.

Replies (13)

RE: gmail noreply problem - Added by max müller about 9 years ago

thx.
but the "Emission email address" is already set to another mailaddress.
it seems that this option doesnt work for me.

RE: gmail noreply problem - Added by Felix Schäfer about 9 years ago

It might be that your mailserver mangles the emission address and sets it to the address of the account you're using to send the mails.

RE: gmail noreply problem - Added by max müller about 9 years ago

Is there a way to figure that out?

RE: gmail noreply problem - Added by Felix Schäfer about 9 years ago

Send a mail from the mail program of your choice to that address and explicitly set the sender address, see if the resulting mail has what you have set in your mail program?

RE: gmail noreply problem - Added by max müller about 9 years ago

thanks for the answer. i will try.

RE: gmail noreply problem - Added by max müller about 9 years ago

mmhhh..
same behaviour. the mailaddress changes back to the mailaddress of the
authenticated user. the only thing that works, i can change the "reply
to" address. is there a way to change this in the email.yml?

thanks m.

RE: gmail noreply problem - Added by Felix Schäfer about 9 years ago

You mean if you can set the reply-to in the email.yml? Not sure, look up the docs for ActionMailer :-)

RE: gmail noreply problem - Added by max müller about 9 years ago

seems not possible. please, can you tell me in what file the
actionmailer is configured for redmine. so maybe i can play with
the header-settings like :reply_to etc.

best m.

RE: gmail noreply problem - Added by Felix Schäfer about 9 years ago

Try adding reply_to "your@address.com" beneath from Setting.mail_from in source:/trunk/app/models/mailer.rb#L343.

RE: gmail noreply problem - Added by max müller about 9 years ago

well, this works for the reply to:.
but of course it's not so nice to change things outside the normal
configuration options.
do you have an idea why the "Emission email address" option isn't working?
the account is google-apps and all mail-traffic goes over the postini-service.

best m.

RE: gmail noreply problem - Added by Felix Schäfer about 9 years ago

max müller wrote:

do you have an idea why the "Emission email address" option isn't working?

I'd wager google overwrites it with the account used. Try with another mail server to make sure.

RE: gmail noreply problem - Added by max müller about 9 years ago

well, i figured out that, first you have to add a second sender address
in gmail or google apps (e.g. ). after that the "Emission email address" setting is working like it should.

thx again for the help

(1-13/13)