Upgrading from 1.2.2 to 1.3.0

Added by Jean-Michel G over 7 years ago

Hello, I have redmine 1.2.2 on Ubuntu Lucid Lynx 10.04 server, but I can't upgrade it.
I follow http://www.redmine.org/projects/redmine/wiki/RedmineUpgrade but When I try rake db:migrate RAILS_ENV=production I have following error:

$ rake db:migrate RAILS_ENV=production
(in /var/www/redmine)
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb713ac9c>

(See full trace by running task with --trace)

$ rake db:migrate RAILS_ENV=production --trace
(in /var/www/redmine)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0xb71879fc>
/var/lib/gems/1.8/gems/rails-2.3.14/lib/rails/gem_dependency.rb:81:in `add_load_paths'

I upgraded rails to 2.3.14 and uninstalled 2.3.11.

Thanks for your help.

Replies (26)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Jean-Michel G over 7 years ago

I did it and it doesn't work for me, that's why I'am asking.
I didn't use svn method.

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Carlos Miranda Molina over 7 years ago

What is result of gem list command....?

:~# gem list

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Jean-Michel G over 7 years ago

# gem list

*** LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
daemons (1.1.4)
gem_plugin (0.2.3)
i18n (0.4.2)
mysql (2.8.1)
rack (1.1.1)
rails (2.3.14)
rake (0.8.7)
rdoc (2.4.2)
rmagick (2.13.1)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Emmanuel BOUGEROLLE over 7 years ago

Hi,

I've the same error for a new installation 1.3.0.

Works fine for 1.2.3.

$ RAILS_ENV=development rake db:migrate
(in /var/www/redmine)
rake aborted!
undefined method `requirement' for #<Rails::GemDependency:0x7faa5de4ae58>

My gems list

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
i18n (0.4.2)
mysql (2.8.1)
rack (1.1.1)
rails (2.3.14)
rake (0.8.7)
rdoc (2.4.2)

Regards,

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Emmanuel BOUGEROLLE over 7 years ago

Ubuntu 10.04 install rubygem 1.3.5 as default.

gem update --sytem command is disable by debian/ubuntu

Donwload the rubygem 1.3.7 version at and execute setup.rb to install.

After this steps it should work.

Regards,

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Jean-Michel G over 7 years ago

Yes it works for me too.

Here is how I did:

# wget production.cf.rubygems.org/rubygems/rubygems-1.3.7.tgz (@#! spam filter I can't write URL)
# tar xvzf rubygems-1.3.7.tgz
# cd rubygems-1.3.7
# ruby setup.rb

# gem install rack -v=1.1.1
# gem install rails -v=2.3.14
# gem install mysql
# gem install i18n
# gem install rmagick
# gem install rdoc -v=2.4.2

$ rake generate_session_store
$ rake config/initializers/session_store.rb
$ rake db:migrate RAILS_ENV=production
$ rake db:migrate_plugins RAILS_ENV=production

$ rake tmp:cache:clear
$ rake tmp:sessions:clear

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

i was making redmine upgrade (every single upgrade i have is with problems)
was upgrading from 1.1.1dev to current build (revision 8325)

First error was when executing rake db:migrate RAILS_ENV=production with some dependancy.
Had also previous version of ruby, so uninstalled it and instaleld new 1.9.3 (it is support as far as i can see in install wiki)

installed all needed gems as well (also mysql and also copied .dll as noted on wiki)

made svn update again and then rake db:migrate RAILS_ENV=production gives me this

C:\redmine>rake db:migrate RAILS_ENV=production
rake aborted!
uninitialized constant Gem::SyckDefaultKey

Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)

mongrel service isn't working (file not found) anymore, too

So, please...what to do next to bring redmine alive again?
Thank you

my system:

ruby 1.9.3p0 (2011-10-30) [i386-mingw32]
*** LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
bigdecimal (1.1.0)
cgi_multipart_eof_fix (2.5.0)
gem_plugin (0.2.3)
i18n (0.6.0)
io-console (0.3)
json (1.5.4)
minitest (2.5.1)
mongrel (1.1.5 x86-mingw32)
mysql (2.8.1 x86-mingw32)
rack (1.1.2, 1.1.1)
rails (2.3.14)
rake (0.9.2.2)
rdoc (2.4.2)
rubygems-update (1.8.13, 1.3.7)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

calling this
ruby script/server webrick -e production, gives me this

C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require': iconv will be deprecated in the future, use String#encode instead.
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21.
C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:466:in `rescue in load_missing_constant': uninitialized const
ant Gem::SyckDefaultKey (NameError)
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:462:in `load_missing_constant'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:106:in `const_missing_with_dependencies'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/requirement.rb:179:in `block in fix_syck_default_key_in_requirements'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/requirement.rb:178:in `each'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/requirement.rb:178:in `fix_syck_default_key_in_requirements'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/requirement.rb:129:in `yaml_initialize'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:135:in `transfer'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:135:in `node_import'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:135:in `load'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:135:in `load'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:146:in `block in load_file'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:145:in `open'
        from C:/Ruby/lib/ruby/1.9.1/syck.rb:145:in `load_file'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:110:in `load_specification'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:48:in `block in refresh!'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:45:in `each'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:45:in `refresh!'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:29:in `initialize'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21:in `new'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21:in `add_frozen_gem_path'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:298:in `add_gem_load_paths'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:132:in `process'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
        from C:/redmine/config/environment.rb:24:in `<top (required)>'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `block in require'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in `new_constants_in'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/commands/server.rb:84:in `<top (required)>'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
        from C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
        from script/server:3:in `<main>'

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

Rake 0.8.7 is up, 0.9x is uninstalled
different error

C:\redmine>rake db:migrate RAILS_ENV=production
C:/Ruby/lib/ruby/gems/1.9.1/gems/rake-0.8.7/lib/rake/alt_system.rb:32: Use RbConfig instead of obsolete and deprecated Config.
(in C:/redmine)
rake aborted!
uninitialized constant Gem::SyckDefaultKey

(See full trace by running task with --trace)

actual gems

*** LOCAL GEMS ***

actionmailer (3.1.3, 2.3.14)
actionpack (3.1.3, 2.3.14)
activemodel (3.1.3)
activerecord (3.1.3, 2.3.14)
activeresource (3.1.3, 2.3.14)
activesupport (3.1.3, 2.3.14)
arel (2.2.1)
bigdecimal (1.1.0)
builder (3.0.0)
bundler (1.0.21)
cgi_multipart_eof_fix (2.5.0)
erubis (2.7.0)
gem_plugin (0.2.3)
hike (1.2.1)
i18n (0.6.0)
io-console (0.3)
json (1.5.4)
mail (2.3.0)
mime-types (1.17.2)
minitest (2.10.0, 2.5.1)
mongrel (1.1.5 x86-mingw32)
multi_json (1.0.4)
mysql (2.8.1 x86-mingw32)
polyglot (0.3.3)
rack (1.3.5, 1.1.2, 1.1.1)
rack-cache (1.1)
rack-mount (0.8.3)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.1.3, 2.3.14)
railties (3.1.3)
rdoc (3.12, 2.4.2)
rubygems-update (1.8.13, 1.3.7)
sprockets (2.0.3)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.31)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Emmanuel BOUGEROLLE over 7 years ago

Redmine 1.3.0 (last stable version) is only available for ruby 1.8.6, 1.8.7.
As I read the wiki Ruby 1.9.3 is only for the trunk.

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

i have the trunk, i used svn update

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

let me make it again, using 1.8.7 now

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

C:\redmine>rake db:migrate RAILS_ENV=production
(in C:/redmine)
rake aborted!
uninitialized constant Gem::SyckDefaultKey

and system

ruby 1.8.7 (2011-06-30 patchlevel 352) [i386-mingw32]
actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
cgi_multipart_eof_fix (2.5.0)
gem_plugin (0.2.3)
mongrel (1.1.5 x86-mingw32)
mysql (2.8.1 x86-mingw32)
rack (1.1.1)
rails (2.3.14)
rake (0.8.7)
rdoc (2.4.2)
rubygems-update (1.8.13)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

C:\redmine>rake db:migrate RAILS_ENV=production --trace
(in C:/redmine)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
uninitialized constant Gem::SyckDefaultKey
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:466:in `load_missing_constant'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:106:in `const_missing'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:179:in `fix_syck_default_key_in_requirements'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:178:in `each'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:178:in `fix_syck_default_key_in_requirements'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:129:in `yaml_initialize'
C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `transfer'
C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `node_import'
C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby/lib/ruby/1.8/yaml.rb:144:in `load_file'
C:/Ruby/lib/ruby/1.8/yaml.rb:143:in `open'
C:/Ruby/lib/ruby/1.8/yaml.rb:143:in `load_file'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:110:in `load_specification'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:48:in `refresh!'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:45:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:45:in `refresh!'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/vendor_gem_source_index.rb:29:in `initialize'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21:in `new'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21:in `add_frozen_gem_path'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:298:in `add_gem_load_paths'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:132:in `process'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
C:/redmine/config/environment.rb:24
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in `new_constants_in'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/tasks/misc.rake:4
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby/bin/rake:19:in `load'
C:/Ruby/bin/rake:19

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Etienne Massip over 7 years ago

I'll be unpleasant but Redmine does not support RubyGems 1.8, there has been already some incompatibilities reported (although not this one).

See also Problem installing Redmine 1.2.2.

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

ok, made gem update --system 1.3.7
and uninstalled 1.8.3

p.s. mysql is still in gem list

C:\redmine>rake db:migrate RAILS_ENV=production --trace
(in C:/redmine)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
rake aborted!
193: %1 is not a valid Win32 application.   - C:/Ruby/lib/ruby/gems/1.8/gems/mysql-2.8.1-x86-mingw32/lib/1.8/mysql_api.so
C:/Ruby/lib/ruby/gems/1.8/gems/mysql-2.8.1-x86-mingw32/lib/1.8/mysql_api.so
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/mysql-2.8.1-x86-mingw32/lib/mysql.rb:7
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/requires.rb:7:in `require_library_or_gem'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/requires.rb:5:in `require_library_or_gem'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/mysql_adapter.rb:61:in `mysql_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in `send'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:223:in `new_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:245:in `checkout_new_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:188:in `checkout'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `loop'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:184:in `checkout'
C:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:183:in `checkout'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:98:in `connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_pool.rb:326:in `retrieve_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_specification.rb:123:in `retrieve_connect
ion'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.14/lib/active_record/connection_adapters/abstract/connection_specification.rb:115:in `connection'
C:/redmine/vendor/plugins/awesome_nested_set/lib/awesome_nested_set.rb:218:in `quoted_left_column_name'
C:/redmine/vendor/plugins/awesome_nested_set/lib/awesome_nested_set.rb:93:in `acts_as_nested_set'
C:/redmine/app/models/issue.rb:37
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:291:in `require_or_load_without_engine_additions'
C:/redmine/vendor/plugins/engines/lib/engines/rails_extensions/dependencies.rb:132:in `require_or_load'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:451:in `load_missing_constant'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:106:in `const_missing'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:118:in `const_missing'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:463:in `load_missing_constant'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:106:in `const_missing'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:463:in `load_missing_constant'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:122:in `const_missing'
C:/redmine/vendor/plugins/redcase/init.rb:114:in `evaluate_init_rb'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:182:in `call'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:182:in `evaluate_method'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:166:in `call'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:90:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:90:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:90:in `send'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:90:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/callbacks.rb:276:in `run_callbacks'
C:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.14/lib/action_controller/dispatcher.rb:51:in `send'
C:/Ruby/lib/ruby/gems/1.8/gems/actionpack-2.3.14/lib/action_controller/dispatcher.rb:51:in `run_prepare_callbacks'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:631:in `prepare_dispatcher'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:185:in `process'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
C:/redmine/config/environment.rb:24
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in `new_constants_in'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/tasks/misc.rake:4
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in `invoke_prerequisites'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `invoke_prerequisites'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in `invoke_with_call_chain'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in `invoke_task'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in `top_level'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby/bin/rake:19:in `load'
C:/Ruby/bin/rake:19

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Etienne Massip over 7 years ago

There are C:/Ruby/lib/ruby/gems/1.8 everywhere, not sure that the downgrade was efficient.

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

freshly installed Ruby 1.8.7 gives me this folder by default, so it ruby 1.8
any more help, please?

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

reinstalled all from the scratch

C:\redmine\config>gem list

*** LOCAL GEMS ***

actionmailer (2.3.14)
actionpack (2.3.14)
activerecord (2.3.14)
activeresource (2.3.14)
activesupport (2.3.14)
mysql (2.8.1 x86-mingw32)
rack (1.1.1)
rails (2.3.14)
rake (0.8.7)
rdoc (2.4.2)
rubygems-update (1.3.7)
C:\redmine\config>rake db:migrate RAILS_ENV=production
(in C:/redmine)
!!! The bundled mysql.rb driver has been removed from Rails 2.2. Please install the mysql gem and try again: gem install mysql.
rake aborted!
193: %1 is not a valid Win32 application.   - C:/Ruby/lib/ruby/gems/1.8/gems/mysql-2.8.1-x86-mingw32/lib/1.8/mysql_api.so

i'm tired :(

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

added mysql dll from repo and now 'all' (rake migrate i mean) is working (need to reconfigure mogrel again)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Etienne Massip over 7 years ago

Alex Guzun wrote:

freshly installed Ruby 1.8.7 gives me this folder by default, so it ruby 1.8
any more help, please?

Yes, sorry about this dumb comment. Glad you succeeded in the end.

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

How can i star redmine now?

ruby script/server webrick -e production
gives me this
ruby: No such file or directory -- script/server (LoadError)

RE: Upgrading from 1.2.2 to 1.3.0 - Added by Alex Guzun over 7 years ago

got it, also
i need to be in a root of working folder to get it properly start, in my case it is (c:\redmine\)

1 2 (1-25/26)