bundle install problems

Added by Ivan Cenov over 5 years ago

Hi,

After finishing issue #5638 I have problems installed required gems. I am running Redmine on Windows XP system. here is the log

D:\biz\apps\redmine_trunk>bundle install
Fetching source index for http://rubygems.org/
Using rake (0.9.2.2)
Using activesupport (2.3.14)
Installing rack (1.1.3)
Using actionpack (2.3.14)
Using actionmailer (2.3.14)
Using activerecord (2.3.14)
Using activeresource (2.3.14)
Installing coderay (1.0.5)
Installing edavis10-object_daddy (0.4.3)
Installing fastercsv (1.5.4)
Using i18n (0.4.2)
Installing json (1.6.5) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

d:/Ruby187/bin/ruby.exe extconf.rb
creating Makefile

make
make: *** No rule to make target `ruby.h', needed by `parser.o'.  Stop.

Gem files will remain installed in d:/Ruby187/lib/ruby/gems/1.8/gems/json-1.6.5 for inspection.
Results logged to d:/Ruby187/lib/ruby/gems/1.8/gems/json-1.6.5/ext/json/ext/parser/gem_make.out
An error occured while installing json (1.6.5), and Bundler cannot continue.
Make sure that `gem install json -v '1.6.5'` succeeds before bundling.

D:\biz\apps\redmine_trunk>
Obviously tehre is a problem with building gem native extensions. This is new to me. I have installed mingw32 with QtCreator and D:\QtSDK\mingw\bin; in in the PATH=. I don't know how to proceed ahead. What do I have to do next? Someone else encountered such problems? Help please...

Replies (12)

RE: bundle install problems - Added by Jean-Philippe Lang over 5 years ago

Remove .bundle/config if present then try:

bundle install --without development test rmagick

This should skip the json gem installation which is not needed to run Redmine.

RE: bundle install problems - Added by Ivan Cenov over 5 years ago

Many thanks for your help, Jean-Philippe Lang!
It works. Here is the log:

D:\biz\apps\redmine_trunk>bundle install --without development test rmagick
Fetching source index for http://rubygems.org/
Using rake (0.9.2.2)
Using activesupport (2.3.14)
Using rack (1.1.3)
Using actionpack (2.3.14)
Using actionmailer (2.3.14)
Using activerecord (2.3.14)
Using activeresource (2.3.14)
Using coderay (1.0.5)
Using fastercsv (1.5.4)
Using i18n (0.4.2)
Using mysql (2.8.1)
Installing net-ldap (0.3.1)
Installing pg (0.9.0)
Using rails (2.3.14)
Using ruby-openid (2.1.8)
Installing sqlite3 (1.3.5)
Using bundler (1.0.22)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

D:\biz\apps\redmine_trunk>ruby script\server -e production
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2012-02-19 21:16:35] INFO  WEBrick 1.3.1
[2012-02-19 21:16:35] INFO  ruby 1.8.7 (2010-08-16) [i386-mingw32]
[2012-02-19 21:16:36] INFO  WEBrick::HTTPServer#start: pid=5012 port=3000
Nevertheless I should see why this
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
happened. Now I am with QT Creator, and will try with pure MingW from http://www.mingw.org/. But this is not Redmine related. I'll dig into it some day.

RE: bundle install problems - Added by Mario Luzeiro over 5 years ago

For me, it gives an error with a message:
"you cannot specify the same gem twice with different version requirements"

RE: bundle install problems - Added by Ivan Cenov over 5 years ago

Mario Luzeiro wrote:

For me, it gives an error with a message:
"you cannot specify the same gem twice with different version requirements"

Why do you think so?

RE: bundle install problems - Added by Mario Luzeiro over 5 years ago

I dont know, I'm using linux, it seams that there are something unstable or I need some instructions to update rake and ruby..

RE: bundle install problems - Added by Ivan Cenov over 5 years ago

Mario Luzeiro wrote:

I dont know, I'm using linux, it seams that there are something unstable or I need some instructions to update rake and ruby..

Sorry, I misunderstood you. My issue was specific to Windows installation.

RE: bundle install problems - Added by Terence Mill over 5 years ago

We are migrating from 1.2.1 to 1.3.2 and have similar problem can csan't get it solved.
Please help!

redmine:/opt # rake -V
rake, version 0.8.7
redmine:/opt # ruby -v
ruby 1.8.7 (2011-02-18 patchlevel 334) [x86_64-linux]
test-redmine:/opt # gem -v
1.3.7
redmine:/opt # rails -v
Rails 2.3.14
redmine:/opt/redmine-1.2.1d3 # cd ../redmine-1.3.2/
redmine:/opt/redmine-1.3.2 # rake config/initializers/session_store.rb RAILS_ENV=production
(in /opt/redmine-1.3.2)
Redmine requires Bundler. Please install it with `gem install bundler`.
redmine:/opt/redmine-1.3.2 # gem install bundler
Successfully installed bundler-1.1.3
1 gem installed
Installing ri documentation for bundler-1.1.3...
Installing RDoc documentation for bundler-1.1.3...
redmine:/opt/redmine-1.3.2 # rake config/initializers/session_store.rb RAILS_ENV=production  --trace
(in /opt/redmine-1.3.2)
rake aborted!
/usr/lib64/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler/dsl.rb:75:in `gem': You cannot specify the same gem twice with different version requirements. You specified: rails (= 2.3.14) and rails (= 3.0.0.beta3)
/opt/redmine-1.3.2/Gemfile:79:in `evaluate'
(eval):4:in `evaluate'
/opt/redmine-1.3.2/Gemfile:77:in `glob'
/opt/redmine-1.3.2/Gemfile:77:in `evaluate'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler/definition.rb:18:in `build'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb:135:in `definition'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb:123:in `load'
/usr/lib64/ruby/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb:107:in `setup'
/opt/redmine-1.3.2/config/../config/preinitializer.rb:16
/opt/redmine-1.3.2/config/boot.rb:33:in `load'
/opt/redmine-1.3.2/config/boot.rb:33:in `preinitialize'
/opt/redmine-1.3.2/config/boot.rb:15:in `boot!'
/opt/redmine-1.3.2/config/boot.rb:124
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/opt/redmine-1.3.2/Rakefile:4
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `load'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2383:in `raw_load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2017:in `load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2016:in `load_rakefile'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2000:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in `standard_exception_handling'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

RE: bundle install problems - Added by Brad Rushworth over 5 years ago

Terence Mill wrote:

We are migrating from 1.2.1 to 1.3.2 and have similar problem can csan't get it solved.
Please help!

Check Gemfile, Gemfile.local and Gemfile.lock in the redmine root folder.

I had to define my Gemfile.local:

# Gemfile.local
gem "lockfile" 
gem "inifile" 

Don't include something like gem "rdoc" because it will complain about conflicted requirements between v0 and v2.4.2 etc. At a guess, it looks like you've specified gem "rails" without specifying a version number, hence bundler wants the latest version and Redmine wants 2.3.14.

As I understand it, this Gemfile.local file then generates the other two when I ran:

bundle install --without development test postgresql sqlite

Also, I'm using mod_fcgid and I found I had to add symbolic links to my public folder to get Apache to work:

ls -la public/
lrwxr-xr-x   1 root  www        10 Apr 17 23:14 Gemfile -> ../Gemfile
lrwxr-xr-x   1 root  www        16 Apr 17 23:14 Gemfile.local -> ../Gemfile.local
lrwxr-xr-x   1 root  www        15 Apr 17 23:14 Gemfile.lock -> ../Gemfile.lock

RE: bundle install problems - Added by alan blount about 5 years ago

I think I found the issue in my install - was with the "redmine_better_gantt_chart" plugin:

# grep i18n * -R | grep '4.2'
Gemfile:gem "i18n", "~> 0.4.2" 
doc/.svn/text-base/CHANGELOG.svn-base:* #6784: Redmine not working with i18n gem 0.4.2
doc/CHANGELOG:* #6784: Redmine not working with i18n gem 0.4.2
vendor/plugins/redmine_better_gantt_chart/Gemfile.lock:    i18n (0.4.2)
vendor/plugins/redmine_better_gantt_chart/Gemfile.lock:  i18n (= 0.4.2)
vendor/plugins/redmine_better_gantt_chart/Gemfile:  gem 'i18n', "0.4.2" 

http://www.redmine.org/plugins/redmine_better_gantt_chart

RE: bundle install problems - Added by web guru over 2 years ago

Hi,
I'm new on ruby on rails, i installed ROR IDE aptana, when i install bundle its giving me this error i really appreciate you if you help me please thanks in advance

Gem files will remain installed in c:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/json-1.8.2 for inspection.
Results logged to c:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/extensions/x86-mingw32/1.9.1/json-1.8.2/gem_make.out
An error occurred while installing json (1.8.2), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.2'` succeeds before bundling.

once again thanks

RE: bundle install problems - Added by Ivan Cenov over 2 years ago

web guru wrote:

Hi,
I'm new on ruby on rails, i installed ROR IDE aptana, when i install bundle its giving me this error i really appreciate you if you help me please thanks in advance

Gem files will remain installed in c:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/json-1.8.2 for inspection.
Results logged to c:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/extensions/x86-mingw32/1.9.1/json-1.8.2/gem_make.out
An error occurred while installing json (1.8.2), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.2'` succeeds before bundling.

once again thanks

It seems the native extensions for json were not built. Make sure to have path to gcc included into PATH= environment variable.

RE: bundle install problems - Added by Shruthi SS over 2 years ago

Hello everyone,
I got this error.Please help me out wile installing plugin..

Your Gemfile lists the gem jquery-ui-rails (>= 0) more than once.
You should probably keep only one of them.
While it's not a problem now, it could cause errors if you change the version of just one of them later.
The source :rubygems is deprecated because HTTP requests are insecure.
Please change your source to 'https://rubygems.org' if possible, or 'http://rubygems.org' if not.
You cannot specify the same gem twice with different version requirements.
You specified: spreadsheet (>= 0) and spreadsheet (~> 0.6.8)

(1-12/12)