Problems upgrading to 1.4.1: Some gems may need to be installed or updated.

Added by André Jonsson over 5 years ago

I wrote this as a comment to the release news item, but perhaps this forum is a better place for it.

I'm having a problem after upgrading (from 1.3.2). Perhaps this is more of a Rails problem than a Readmine one.

After upgrading (using svn switch on my working copy), I ran the migrate script:

# rake db:migrate RAILS_ENV=production
Redmine requires Bundler. Please install it with `gem install bundler`.

ok, simple enough:

# sudo gem install bundler
Successfully installed bundler-1.1.3
1 gem installed

Running migrate again:

# rake db:migrate RAILS_ENV=production
Some gems may need to be installed or updated.
Please run `bundle install --without development test`.

Trying as told:

# bundle install --without development test
bundle: Command not found.

hm... I have no bundle executable...
I found there's one at /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle (have no idea if that's the same one), but running that:

# /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle install --without development test
/var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle:2:in `require': no such file to load -- bundler (LoadError)
 from /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle:2

even more hmm... having no idea why that was (I have no ruby skills), I tried setting the require path to an absolute one in the bundle script:
require '/var/lib/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb'

That produced another error:

/var/lib/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb:4:in `require': no such file to load -- bundler/psyched_yaml (LoadError)
 from /var/lib/gems/1.8/gems/bundler-1.1.3/lib/bundler.rb:4
 from /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle:2:in `require'
 from /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle:2

Here's where I failed come up with any more (bad) ideas on how to go about fixing this... and I felt my attempts is bringing me further and further from the real problem...

Sorry for the long-winded explanation, but I thought more is probably better then less.
What am I missing?

# gem list

*** LOCAL GEMS ***

actionmailer (3.2.3, 2.3.14, 2.3.11)
actionpack (3.2.3, 2.3.14, 2.3.11)
activemodel (3.2.3)
activerecord (3.2.3, 2.3.14, 2.3.11)
activeresource (3.2.3, 2.3.14, 2.3.11)
activesupport (3.2.3, 2.3.14, 2.3.11)
arel (3.0.2)
builder (3.0.0)
bundler (1.1.3)
erubis (2.7.0)
hike (1.2.1)
i18n (0.6.0, 0.4.2)
journey (1.0.3)
json (1.7.0)
mail (2.4.4)
mime-types (1.18)
mini_magick (3.4, 3.3)
multi_json (1.3.4)
oniguruma (1.1.0)
plist (3.1.0)
polyglot (0.3.3)
rack (1.4.1, 1.1.2)
rack-cache (1.2)
rack-test (0.6.1)
rails (2.3.14)
rake (0.9.2.2, 0.9.2)
rdoc (3.12)
sprockets (2.1.3)
subexec (0.2.2, 0.1.0)
textpow (0.10.1)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.33)
ultraviolet (0.10.2)

edit: edited for readability and added gem list

Replies (5)

RE: Problems upgrading to 1.4.1: Some gems may need to be installed or updated. - Added by André Jonsson over 5 years ago

As it happened I decided to upgrade my linux distribution, and after that this problem did not appear.
So.... nevermind, I guess.

RE: Problems upgrading to 1.4.1: Some gems may need to be installed or updated. - Added by Condor Support over 5 years ago

Helo André, I am facing the same problem with a Debian squeeze. I could install the 1.0.1 version from the repository.
Now I want to install 1.4 and I can't.

Only upgrading the OS is the solution? do you know why?

Regards,
Manuel

RE: Problems upgrading to 1.4.1: Some gems may need to be installed or updated. - Added by André Jonsson over 5 years ago

Unfortunately, no. Ruby and Rails is far outside my area of expertise. :(

However, now that I checked the "bundle" executable now installed, I see that it's not at all the same file as /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle.

For reference, here's the content of my /usr/local/bin/bundle file:

#!/usr/bin/ruby1.8
#
# This file was generated by RubyGems.
#
# The application 'bundler' is installed as part of a gem, and
# this file is here to facilitate running it.
#

require 'rubygems'

version = ">= 0" 

if ARGV.first =~ /^_(.*)_$/ and Gem::Version.correct? $1 then
  version = $1
  ARGV.shift
end

gem 'bundler', version
load Gem.bin_path('bundler', 'bundle', version)

If that helps...

RE: Problems upgrading to 1.4.1: Some gems may need to be installed or updated. - Added by Bruno Passos over 5 years ago

Try to link 'bundle' to your /usr/bin/. The command that I used was "ln -s /var/lib/gems/1.8/bin/bundle /usr/bin/"

worked for me

RE: Problems upgrading to 1.4.1: Some gems may need to be installed or updated. - Added by Condor Support over 5 years ago

Yes, /var/lib/gems/1.8/bin/bundle instead of /var/lib/gems/1.8/gems/bundler-1.1.3/bin/bundle worked for me too.

After that I had hundreds of other errors, but I could solve them (for example installing mysql-devel) looking at the forum.

Thanks for the help!

(1-5/5)