can not start redmine 2.02

Added by Timmy Schweer over 6 years ago

Hi guys,
I've just wasted about 5 hours with this problem.. I already runned redmine 1.x but 2.x kills me...

I tried with "Mongrel-cluster" and "Thin", clear installation and upgrade from 1.x, reinstalled all gems, tried current trunk and 2.0.2...
  • always the same message:
    /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require': no such file to load -- dispatcher (LoadError)
            from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
            from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:236:in `load_dependency'
            from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.5/lib/active_support/dependencies.rb:251:in `require'
            from /usr/lib/ruby/1.8/rack/adapter/rails.rb:44:in `load_application'
            from /usr/lib/ruby/1.8/rack/adapter/rails.rb:23:in `initialize'
            from /usr/lib/ruby/1.8/rack/adapter/loader.rb:36:in `new'
            from /usr/lib/ruby/1.8/rack/adapter/loader.rb:36:in `for'
            from /usr/lib/ruby/1.8/thin/controllers/controller.rb:163:in `load_adapter'
            from /usr/lib/ruby/1.8/thin/controllers/controller.rb:67:in `start'
            from /usr/lib/ruby/1.8/thin/runner.rb:174:in `send'
            from /usr/lib/ruby/1.8/thin/runner.rb:174:in `run_command'
            from /usr/lib/ruby/1.8/thin/runner.rb:140:in `run!'
            from /usr/bin/thin1.8:6
    
  • here is my runtime environment:
    Ubuntu 10.04 Server
    ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]
    Rails 3.2.5
    
  • my gems:
    actionmailer (3.2.5)
    actionpack (3.2.5)
    activemodel (3.2.5)
    activerecord (3.2.5)
    activeresource (3.2.5)
    activesupport (3.2.5)
    arel (3.0.2)
    builder (3.0.0)
    bundle (0.0.1)
    bundler (1.1.4)
    coderay (1.0.6)
    daemons (1.1.8)
    erubis (2.7.0)
    eventmachine (0.12.10)
    fastercsv (1.5.5)
    hike (1.2.1)
    i18n (0.6.0)
    journey (1.0.3)
    json (1.7.3)
    mail (2.4.4)
    mime-types (1.18)
    mongrel (1.1.5)
    mongrel_cluster (1.0.5)
    multi_json (1.3.6)
    mysql (2.8.1)
    net-ldap (0.3.1)
    polyglot (0.3.3)
    prototype-rails (3.2.1)
    rack (1.4.1)
    rack-cache (1.2)
    rack-openid (1.3.1)
    rack-ssl (1.3.2)
    rack-test (0.6.1)
    rails (3.2.5)
    railties (3.2.5)
    rake (0.9.2.2)
    rdoc (3.12)
    ruby-openid (2.1.8)
    sprockets (2.1.3)
    thin (1.3.1)
    thor (0.15.2)
    tilt (1.3.3)
    treetop (1.4.10)
    tzinfo (0.3.33)
    
  • this works fine =(:
    ruby script/rails server webrick -e production
    

Replies (6)

RE: can not start redmine 2.02 - Added by 睿 双 over 6 years ago

The same problem!Keep an eye on!

RE: can not start redmine 2.0.3 - Added by Timo Erbach over 6 years ago

I also got such an error:

/usr/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require': no such file to load -- dispatcher (LoadError)
from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:236:in `load_dependency'
from /usr/lib/ruby/gems/1.8/gems/activesupport-3.2.6/lib/active_support/dependencies.rb:251:in `require'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:148:in `rails'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:113:in `cloaker_'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `call'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:149:in `listener'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:99:in `cloaker_'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `call'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:50:in `initialize'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `new'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:84:in `run'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:in `run'
from /usr/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
from /usr/bin/mongrel_rails:23:in `load'
from /usr/bin/mongrel_rails:23

Before upgrading to v2 redmine with v1.3 ran many years with no error.
I need this tool! So it's anoying...

RE: can not start redmine 2.02 - Added by Etienne Massip over 6 years ago

Mongrel is not maintained anymore and I think it is not compatible with Rails 3.x (and was not with latest 2.x neither) so I advise you to find a replacement.

I don't know about thin.

RE: can not start redmine 2.02 - Added by Timo Erbach over 6 years ago

Ah, thanks. I just put webrick behind apache. That solved the problem, but is only a workaround. I think I#ll try passenger.

Thanks again!

Regrads Timo

RE: can not start redmine 2.02 - Added by al la over 6 years ago

Hi,

I have a fresh installed redmine with stuff-todo plugin and have the same error.

To me it looks like that the plugin developer have not moved to Rails 3.

http://www.redmine.org/boards/3/topics/30423

RE: can not start redmine 2.02 - Added by cam lafit over 6 years ago

Hi

I've resolved this problem with this procedure. In my case, I use a debian distribution.

  • remove thin scripts/package
    • apt-get remove thin
    • kill all thin process
  • specify that redmine require thin
    • create/update Gemfile.local in your redmine directory with gem "thin"
  • relaunch bundle script
    • bundle install [--without development test]
  • update script thin daemon
    • nano /etc/init.d/thin1.8
    • DAEMON=/var/lib/gems/1.8/bin/thin
Now thin will be ok to start with last redmine version
  • /etc/init.d/thin1.8 start

(1-6/6)