anyone has met this issue?

Added by Steven Wong over 7 years ago

I really do not know why it happened .

when several user use redmine in the same time ,ex. when userA report issue and submit, but the author would be modified to userB.

http://www.redmine.org/issues/11624

Please help me...

Thanks much.

Replies (52)

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

HI, A M
the plugin has been updated for redmine 2.0.3, you can get the newest version from github.

A M wrote:

Steven Wong wrote:

I've installed many plugins. as follows:
[...]
redmine_close_button                     0.0.8

Is this the Close Issue Button (http://www.redmine.org/plugins/redmine_close_button)? I'm asking because you are running Redmine version 2.0.3 and this plugin doesn't say it is compatible with Redmine 2.0.3. Thanks.

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

Hi, Etienne Massip

I think I have never change anything about cache and session..

strange so much.

anyone have any solution...

I tried to clear the cache, but the problem is still here.

==how to reproduce it?
1. login as A
2. open new issues
3. another user login as B
4. then A submit new issue..... Owww.. the author would be B(why it happened? how to fix it.)

I tried many methods, but can not fixed it.

is it the bug of redmine???
or I do something wrong.

My environment is remdine 2.0.3, the database is bansed and updated from 1.4.4.

Thanks so much.

Etienne Massip wrote:

Steven Wong wrote:

Jon Lumpkin wrote:

You should only have to do that after the upgrade and then be good to go.

Slightly off topic, but how does your log show the SQL, time, etc?

change you log level in configuration file in config folder.

Did you also change your cache provider or any cache-related setting?

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Did you remove session_store.rb file and generated a secret_token as described in RedmineUpgrade#Generating-a-new-secret_token.rb?

RE: anyone has met this issue? - Added by Artur M over 7 years ago

Steven Wong wrote:

HI, A M
the plugin has been updated for redmine 2.0.3, you can get the newest version from github.

A M wrote:

Steven Wong wrote:

I've installed many plugins. as follows:
[...]
redmine_close_button                     0.0.8

Is this the Close Issue Button (http://www.redmine.org/plugins/redmine_close_button)? I'm asking because you are running Redmine version 2.0.3 and this plugin doesn't say it is compatible with Redmine 2.0.3. Thanks.

Hi Steven Wong,
I don't know if this is a little off-topic but in the GitHub Commits there is the following information:

'Compactible with Redmine 2.x
  1. modified the readme - add changelog
  2. modified to compactible with Redmine 2.x.
    I just test it for Redmine 2.0.3 and it works well.
    sorry for that I am a beginner for rails, if there's any problem, please
    inform the author or any other one forked the plugins.
    Thanks.
    commit ce080e9d333f189d835ac7b3bb4cf1c86c897ce4 1 parent 1c353dfb0b
    archonwang authored 17 days ago'

So, it seems that the plugin compatibility was changed to Compatible Redmine 2.x only because "it was tested and worked well". Is this enough? Wouldn't be wiser to wait for the author's opinion?

Thanks.

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

Hi, A M

that's all right. and at present, I used the repos works well and my environment is redmine 2.0.3.

I am not sure whether it works well on the other versions. by the way, I think you can try it if your environment is 2.0.3, or you can contact the author for some more information.

If you have any problem, please contact the plugin author or leave message on github. It would be nice.

Thanks so much.

A M wrote:

Steven Wong wrote:

HI, A M
the plugin has been updated for redmine 2.0.3, you can get the newest version from github.

A M wrote:

Steven Wong wrote:

I've installed many plugins. as follows:
[...]
redmine_close_button                     0.0.8

Is this the Close Issue Button (http://www.redmine.org/plugins/redmine_close_button)? I'm asking because you are running Redmine version 2.0.3 and this plugin doesn't say it is compatible with Redmine 2.0.3. Thanks.

Hi Steven Wong,
I don't know if this is a little off-topic but in the GitHub Commits there is the following information:

'Compactible with Redmine 2.x
  1. modified the readme - add changelog
  2. modified to compactible with Redmine 2.x.
    I just test it for Redmine 2.0.3 and it works well.
    sorry for that I am a beginner for rails, if there's any problem, please
    inform the author or any other one forked the plugins.
    Thanks.
    commit ce080e9d333f189d835ac7b3bb4cf1c86c897ce4 1 parent 1c353dfb0b
    archonwang authored 17 days ago'

So, it seems that the plugin compatibility was changed to Compatible Redmine 2.x only because "it was tested and worked well". Is this enough? Wouldn't be wiser to wait for the author's opinion?

Thanks.

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

Hi, Etienne Massip

I delete the secret_token file and rebuild it.

Hope it could be useful....

Thanks.

Etienne Massip wrote:

Did you remove session_store.rb file and generated a secret_token as described in RedmineUpgrade#Generating-a-new-secret_token.rb?

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

Hi, I tested it and the problem not be solved....

it makes me crazy....

Etienne Massip wrote:

Did you remove session_store.rb file and generated a secret_token as described in RedmineUpgrade#Generating-a-new-secret_token.rb?

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Did you remove session_store.rb file and generated a secret_token as described in RedmineUpgrade#Generating-a-new-secret_token.rb?

We just installed (no upgrade!) this Redmine-version. So we never had this file on our system.

Of course we tried to rebuild secret_token - also no success :(

Is there any line in any file of Redmine which contains proxy- or server-settings?

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Tobias Eskowitz wrote:

We just installed (no upgrade!) this Redmine-version. So we never had this file on our system.

But plugins?

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Tobias Eskowitz wrote:

We just installed (no upgrade!) this Redmine-version. So we never had this file on our system.

But plugins?

Of course we had some... But since 1-2 weeks there are no plugins installed anymore.

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Which ones?

At least:

- apijs
- default_columns
- embedded
- favourite_projects
- knowledgebase
- plugin_views_revisions
- Tab
- Wiki-Extensions
- Wiki-HTML-Util
- XLS-Export
- Stuff to do

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Tobias Eskowitz wrote:

So: Where can the proxy- and cache-settings be configured?

Well, I guess it uses HTTP_PROXY environment variable, and cache settings are in config/application.rb and config/environmnent/production.rb.

Are you using thin too? Which version?

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Are you using thin too? Which version?

Yes, version 1.4.1

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Could you just try to reproduce with any other server?

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

We used Puma before - same errors.

Would it be helpful to use just another server? Which one?

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Tobias Eskowitz wrote:

Would it be helpful to use just another server? Which one?

No, it's ok with 2, this is not a server error.

Could that be that the 2 users share the same email (it should not have any impact but I'm desesperate) or something similar?

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Could that be that the 2 users share the same email (it should not have any impact but I'm desesperate) or something similar?

No, every user has his own address (just same domain). :(

application.rb and production.rb are identical with Redmine-files (2.0.3) after download.

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

I have to roll back remdine to 1.4.4, and then the problem disappear..

I'm not sure why it happened and I have not found how to solve it....

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

I just compared the complete Redmine-files after download from server with the Redmine-files on my server:

In \public there are some/many files (css, js, png, gif) of various plugins which are not installed anymore.

That´s the only difference.

Would it make sense to delete all these files and have a look if the error is solved?

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Tobias Eskowitz wrote:

I just compared the complete Redmine-files after download from server with the Redmine-files on my server:

In public there are some/many files (css, js, png, gif) of various plugins which are not installed anymore.

That´s the only difference.

Would it make sense to delete all these files and have a look if the error is solved?

Yes it would.

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Etienne Massip wrote:

Tobias Eskowitz wrote:

In public there are some/many files (css, js, png, gif) of various plugins which are not installed anymore.

That´s the only difference.

Would it make sense to delete all these files and have a look if the error is solved?

Yes it would.

I did the change 19 hours ago - the problem did not occurred up to now. But: The CSS get lost sometimes at some PCs... Refresh the website helps. Any idea?

See attached image...

11 50 15.jpg (99.4 KB)

RE: anyone has met this issue? - Added by Steven Wong over 7 years ago

Interesting.

should I delete all the files in the public folder???

or the public folders there's something wrong?

I will try it later. Hope it would solve my problem.

RE: anyone has met this issue? - Added by Tobias Eskowitz over 7 years ago

Tobias Eskowitz wrote:

Etienne Massip wrote:

Tobias Eskowitz wrote:

In public there are some/many files (css, js, png, gif) of various plugins which are not installed anymore.

That´s the only difference.

Would it make sense to delete all these files and have a look if the error is solved?

Yes it would.

I did the change 19 hours ago - the problem did not occurred up to now. But: The CSS get lost sometimes at some PCs... Refresh the website helps. Any idea?

See attached image...

Okay... 3 minutes ago the user-switch-problem occurred again. It seems the CSS-load-errors is caused by the same error/mistake, doesn´t it?

RE: anyone has met this issue? - Added by Etienne Massip over 7 years ago

Maybe you should have cleared the cache again after assets deletion?

1 2 3 (26-50/52)