Redmine reminder plug-in error

Added by li an about 3 years ago

Hi,
I installed redmine reminder plug-in,and set this command as auto-task to trigger reminder. Before it runs normally, these days I checked the command, it has such error seems for the version of rake.

//////////////////////ERROR///////////////////////////////
D:\BitNami\redmine-2.3.2-0\apps\redmine\htdocs\plugins>rake redmine:redmine_reminder:send_reminder_mails RAILS_ENV=production
(in D:/BitNami/redmine-2.3.2-0/apps/redmine/htdocs)
rake aborted!
Gem::LoadError: You have already activated rake 10.3.2, but your Gemfile requir
s rake 0.9.2.2. Using bundle exec may solve this.
D:/BitNami/redmine-2.3.2-0/apps/redmine/htdocs/config/boot.rb:6:in `<top (requi
ed)>'
D:/BitNami/redmine-2.3.2-0/apps/redmine/htdocs/config/application.rb:1:in `<top
(required)>'
D:/BitNami/redmine-2.3.2-0/apps/redmine/htdocs/rakefile:5:in `<top (required)>'
(See full trace by running task with --trace)
/////////////////////////////////
So I added bundle exec before this command,then there is such message, can anyone help to solve that?

//////////////////////////added bundle exec///////////////////////
D:\BitNami\redmine-2.3.2-0\apps\redmine\htdocs\plugins>bundle exec rake redmine:
redmine_reminder:send_reminder_mails RAILS_ENV=production
The source :rubygems is deprecated because HTTP requests are insecure.
Please change your source to 'https://rubygems.org' if possible, or 'http://ruby
gems.org' if not.
(in D:/BitNami/redmine-2.3.2-0/apps/redmine/htdocs)
D:/BitNami/redmine-2.3.2-0/ruby/lib/ruby/gems/1.9.1/gems/watchr-0.7/lib/watchr.r
b:111: Use RbConfig instead of obsolete and deprecated Config.
//////////////////////////////////////////////////////////////

Replies (2)

RE: Redmine reminder plug-in error - Added by Jean-Baptiste Barth about 3 years ago

You're posting to the wrong forum, if you have an error in a specific plugin you should contact the plugin author directly.

RE: Redmine reminder plug-in error - Added by li an about 3 years ago

I have resolved the problem, thanks for your reply, but I think it is all right to post here, for many other redmine users may use that plug-in, if they have solution, it will help one who met issues to resolve quickly.

(1-2/2)