Defect #10277

Redmine wikitext URL-into-link creation with hyphen is wrong

Added by Fares Abdullah almost 6 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Text formatting
Target version:2.3.0
Resolution:Fixed Affected version:1.3.1

Description

Redmine 1.3.0

Typing test-www.example.com creates a link only for the "www.example.com" part, but the host is "test-www", and not "www".

Associated revisions

Revision 11474
Added by Jean-Philippe Lang over 4 years ago

Restricts characters before auto links (#10277).

Revision 11566
Added by Jean-Philippe Lang over 4 years ago

Merged r11474 from trunk (#10277).

History

#1 Updated by Fares Abdullah almost 6 years ago

I have to use <pre> to describe the above:

Typing test-www.example.com creates a link only for the "www.example.com" part, but the host is "test-www", and not "www".

#2 Updated by fangzheng (方正) over 5 years ago

How about adding the prefix "http"?

That will create the link as:
http://test-www.example.com

Maybe the Text formatting is not that smart as we expect ;)

#3 Updated by Etienne Massip over 5 years ago

  • Category set to Text formatting
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release
  • Affected version (unused) set to 1.3.1
  • Affected version set to 1.3.1

#4 Updated by fangzheng (方正) over 5 years ago

Maybe the "www" is the root cause?

See in below:

test@example.com
test@www.com


By the way, most URLs can not be recognized w/o "www" (and prefix).
e.g.
news.google.com

#5 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next minor release to 2.3.0
  • Resolution set to Fixed

Fixed in r11474. test-www.example.com will no longer generate a broken link. Use protocol (eg. http://) for URLs that does not start with www.

#6 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from Resolved to Closed

Merged.

Also available in: Atom PDF