Defect #11006

next previous function not available if issue is closed

Added by Arnaud Dulieu over 5 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:1.4.1

Description

When a issue is set to closed, the Next - Previous function is not available anymore.

It is useful that the Next Previous can still be used for any issue in the list defined based on the filter used.

RedmineNextProv-closedstatus.pdf (51.7 KB) Arnaud Dulieu, 2012-05-24 10:10

issues_controller.diff Magnifier (2.06 KB) zhiguo Zhu, 2014-05-19 10:27

issues_controller.diff Magnifier (2.21 KB) zhiguo Zhu, 2015-05-19 13:10


Related issues

Duplicates Redmine - Feature #14462: Previous/next links may be lost after editing the issue Closed

History

#1 Updated by Etienne Massip over 5 years ago

Can't reproduce on trunk.

Any installed plugin that could change the behavior?

#2 Updated by Arnaud Dulieu over 5 years ago

This is the way to reproduce it:
- open a issue that is not in status closed
- update the issue
- change the status to close
- submit

The save is ok "Successful update." but then the next/previous links are not displayed anymore.

Plugin installed:

Redmine Close Button plugin
This is the Close Issue button plugin for Redmine
http://github.com/Undev/redmine_close_button
0.0.8

Redmine Notice plugin
This plugin allows you to disable the notification of the closed tasks
https://github.com/parshukovvv/redmine_notify
Vladimir Parshukov 1.0.0

#3 Updated by Etienne Massip over 5 years ago

Are you sure they were displayed before you closed the issue?

I mean, they are displayed if only if you have a query applied whichever is the status of the issue.

#4 Updated by zhiguo Zhu over 3 years ago

+1

#5 Updated by zhiguo Zhu over 3 years ago

fix it for v2.5.1

#6 Updated by Toshi MARUYAMA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate with #14462.

#7 Updated by Toshi MARUYAMA over 3 years ago

  • Duplicates Feature #14462: Previous/next links may be lost after editing the issue added

#8 Updated by zhiguo Zhu over 2 years ago

fix for redmine-3.0.3

Also available in: Atom PDF