Patch #1103

Add deleting of wiki page individual versions

Added by W Snyder over 11 years ago. Updated over 6 years ago.

Status:ClosedStart date:2008-04-25
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-

Description

This is the beginning of a patch to add "Delete" to all but the most recent version of the wiki history list, this cleans up the history - without the mess of "destroy" then adding back the page.

This isn't a complete patch; I'm just starting picking up ruby, and aren't sure of the next step; can someone help a bit?

I got as far as wiki_page.rb delete_version. This takes a version number and correctly does find_by_version, but how do I destroy the passed version?

Thanks for the help.

a.patch Magnifier (2.6 KB) W Snyder, 2008-04-25 03:25


Related issues

Duplicated by Redmine - Feature #10852: Ability to delete a version from a wiki page history Closed

History

#1 Updated by Bruce Svare over 6 years ago

Duplicate of #10852

#2 Updated by W Snyder over 6 years ago

  • Status changed from New to Resolved

#3 Updated by Etienne Massip over 6 years ago

  • Category set to Wiki
  • Status changed from Resolved to Closed

Also available in: Atom PDF