Defect #11922

bs.yml and de.yml lead to error by number_to_currency()

Added by Miko Kinski about 5 years ago. Updated about 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:I18n
Target version:2.1.1
Resolution:Fixed Affected version:2.0.0

Description

default settings in format are overwritten by empty separator, delimiter, precision in currency block which leads to following error

ActionView::Template::Error (wrong argument type nil (expected Fixnum)):

actionpack (3.2.6)

I do not know how to fix this while not changing the de.yml local of redmine

delocal.patch Magnifier (375 Bytes) Miko Kinski, 2012-09-24 20:55

Associated revisions

Revision 10475
Added by Toshi MARUYAMA about 5 years ago

add tests that i18n currency options are nil to 1.4-stable Rails2 (#11922)

Revision 10476
Added by Toshi MARUYAMA about 5 years ago

fix number_to_currency() raises exception on Rails3 bs and de locale (#11922)

Revision 10479
Added by Toshi MARUYAMA about 5 years ago

Merged r10476 from trunk (#11922)

fix number_to_currency() raises exception on Rails3 bs and de locale.

History

#1 Updated by Toshi MARUYAMA about 5 years ago

  • Category set to I18n

#2 Updated by Etienne Massip about 5 years ago

When do you get the error exactly?

#3 Updated by Miko Kinski about 5 years ago

see https://github.com/mkinski/redmine_inventory_manager

If I have some price value like 0.2 in Dollar (English) and Euro (Spain) it works perfect but If I switch to german language it leads to internal error because of number_to_currency function

I am using redmine v2.0.4

#4 Updated by Toshi MARUYAMA about 5 years ago

  • Tracker changed from Patch to Defect
  • Subject changed from de.yml leads to error by number_to_currency() to bs and de lead to error by number_to_currency()
  • Status changed from New to Confirmed
  • Target version set to 2.1.1
  • Affected version (unused) set to 2.0.0
  • Affected version set to 2.0.0

#5 Updated by Toshi MARUYAMA about 5 years ago

  • Subject changed from bs and de lead to error by number_to_currency() to bs.yml and de.yml lead to error by number_to_currency()

#6 Updated by Jean-Philippe Lang about 5 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Fixed

Also available in: Atom PDF