Defect #12979

Wiki link syntax commit:repo_a:abcd doesn't work

Added by Danil Tashkinov almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Text formatting
Target version:2.2.3
Resolution:Fixed Affected version:

Description

The wiki syntax commit:repo_a used to link hash-named changesets doesn't work if repo identifier has underscore symbol.

Maybe in this code https://github.com/redmine/redmine/blob/master/app/helpers/application_helper.rb#L751 used wrong regular expression.

          when 'commit', 'source', 'export'
            if project
              repository = nil
              if name =~ %r{^(([a-z0-9\-]+)\|)(.+)$}
                repo_prefix, repo_identifier, name = $1, $2, $3
                repository = project.repositories.detect {|repo| repo.identifier == repo_identifier}
              else
                repository = project.repository
              end

REDMINE_LINK_TO_COMMIT.diff Magnifier (636 Bytes) Danil Tashkinov, 2013-01-25 10:09


Related issues

Duplicated by Redmine - Defect #13005: Can't link to changeset or source in repository that cont... Closed

Associated revisions

Revision 11281
Added by Jean-Philippe Lang almost 5 years ago

Wiki links to repositories with underscore their identifiers don't work (#12979).

Revision 11362
Added by Jean-Philippe Lang almost 5 years ago

Merged r11281 from trunk (#12979).

History

#1 Updated by Etienne Massip almost 5 years ago

  • Tracker changed from Patch to Defect
  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release

Confirmed because I've observed the same behavior on my instance a week or two ago, but didn't dig into it.

#2 Updated by Jean-Philippe Lang almost 5 years ago

  • Category changed from Wiki to Text formatting
  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next minor release to 2.2.3
  • Resolution set to Fixed

Fixed in r11281, the proposed path was not working.
Thanks for pointing this out.

#3 Updated by Jean-Philippe Lang almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF