Feature #13329

Ruby 2.0 support

Added by Jean-Philippe Lang over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Ruby support
Target version:2.3.0
Resolution:Fixed

Related issues

Related to Redmine - Defect #13327: SystemStackError (stack level too deep): Closed
Related to Redmine - Patch #13338: Remove "warning: class variable access from toplevel" in ... Closed

Associated revisions

Revision 11488
Added by Toshi MARUYAMA over 4 years ago

Ruby2.0: add "require 'yaml'" to Gemfile

On ruby 2.0.0p0 (2013-02-24 revision 39474) [x86_64-linux]:

$ ruby script/about
There was an error in your Gemfile, and Bundler cannot continue.

Revision 11497
Added by Jean-Philippe Lang over 4 years ago

Fixed that #reload raises a Stack too deep error with ruby 2.0.

Revision 11506
Added by Jean-Philippe Lang over 4 years ago

Regexp not working as expected with ruby 2.0.

Revision 11507
Added by Jean-Philippe Lang over 4 years ago

Test failure with ruby 2.0.

Revision 11527
Added by Toshi MARUYAMA over 4 years ago

Ruby2.0: remove "warning: class variable access from toplevel" in lib/plugins/rfpdf/lib/tcpdf.rb (#13338, #13329)

Contributed by Jun NAITOH.

Revision 11533
Added by Toshi MARUYAMA over 4 years ago

Merged r11527 from trunk to 2.3-stable (#13338, #13329)

Ruby2.0: remove "warning: class variable access from toplevel" in lib/plugins/rfpdf/lib/tcpdf.rb.

Contributed by Jun NAITOH.

Revision 11574
Added by Jean-Philippe Lang over 4 years ago

Merged r11497 from trunk (#13329).

Revision 11575
Added by Jean-Philippe Lang over 4 years ago

Merged r11506 from trunk (#13329).

Revision 11576
Added by Jean-Philippe Lang over 4 years ago

Merged r11507 from trunk (#13329).

History

#1 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next major release to 2.3.0
  • Resolution set to Fixed

Ruby 2.0.0 added to the CI server.

#2 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from Closed to Resolved

To be merged in 2.3-stable.

#3 Updated by Jean-Philippe Lang over 4 years ago

  • Status changed from Resolved to Closed

#4 Updated by Etienne Massip over 4 years ago

Please note that Redmine doesn't work with Ruby 2.0.0 under Windows for now because of numerous gem incompatibilities when gems bundle binaries compiled against specific Ruby versions and not 2.0.

Observed with sqlite3 and freetds gems.

This should be stated in documentation.

#5 Updated by Matt Connolly over 4 years ago

Etienne, did you upgrade from ruby 1.9.3? Ruby 2.0.0 has a new binary interface for extensions, so upgrading from 1.9.3 to 2.0.0 will require any gems with extensions to have those extensions recompiled.

#6 Updated by Etienne Massip over 4 years ago

Matt Connolly wrote:

Etienne, did you upgrade from ruby 1.9.3? Ruby 2.0.0 has a new binary interface for extensions, so upgrading from 1.9.3 to 2.0.0 will require any gems with extensions to have those extensions recompiled.

That is true for sqlite3 indeed; as for SQL Server I was pretty sure I got errors from a fresh install on a 32 bit OS but it's been a while now and I don't remember well.

If you got success running Redmine 2.3.x with SQL Server on Windows, you can fix the guide or let me know and I'll remove the warning.

Also available in: Atom PDF