Feature #14660

Excluding "related to" relation from circular dependency check

Added by Toru Haraguchi about 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Given there are three tickets,

  • task-A
  • task-B
  • task-C

on a tracker named "tasks".

Relations are set
  • task-A precedes task-B
  • task-B precedes task-C

These are kind of processes that hand works to another.

  • We want to set "related to" relation between task-A and task-C, because the output of the task-A becomes input of task-C.
  • However, Redmine 2.2.2 and Redmine 2.3.2 does not allow us to do it, says "This relation would create a circular dependency".
  • Please reconsider excluding "related to" from circular dependency check. So far I am thinking that it will not cause contradiction.
  • Apparently, re-entering X-Y relation as Y-X is unnecessary and should be blocked.

Related issues

Duplicates Redmine - Defect #8628: "Related to" reference may yield circular dependency erro... Closed 2011-06-16

History

#1 Updated by Toru Haraguchi about 4 years ago

Indentation was treated as block quote(?) by the wiki engine. Please reformat it, as I do not have the right.

#2 Updated by Toshi MARUYAMA about 4 years ago

  • Description updated (diff)

#3 Updated by Toshi MARUYAMA about 4 years ago

Toru Haraguchi wrote:

Indentation was treated as block quote(?) by the wiki engine. Please reformat it, as I do not have the right.

Done.

#4 Updated by @ go2null over 3 years ago

Duplicate of Defect #8628 "Related to" reference may yield circular dependency error message

#5 Updated by Toshi MARUYAMA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

@ go2null wrote:

Duplicate of Defect #8628 "Related to" reference may yield circular dependency error message

Thank you for your pointing.

#6 Updated by Toshi MARUYAMA over 3 years ago

  • Duplicates Defect #8628: "Related to" reference may yield circular dependency error message added

#7 Updated by Toshi MARUYAMA over 3 years ago

  • Category changed from Issues planning to Issues

Also available in: Atom PDF