Defect #8628

"Related to" reference may yield circular dependency error message

Added by Christian Zagrodnick almost 7 years ago. Updated almost 2 years ago.

Status:ClosedStart date:2011-06-16
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:3.3.0
Resolution:Fixed Affected version:

Description

The "related to" reference is neither directed nor declaring a dependency. Thus the error "This relation would create a circular dependency" seems wrong. "Related to" references should be possible in any case, should they not?

fix_issue_relations.diff Magnifier (853 Bytes) Egbert van der Wal, 2014-05-12 18:10

fix_issue_relations.diff Magnifier (655 Bytes) Egbert van der Wal, 2014-05-12 18:13

issue_relation_test.patch Magnifier (1.82 KB) Uwe Koloska, 2014-09-05 16:42


Related issues

Related to Redmine - Defect #16818: 'copied_to' shouldn't conflict with other relation types New
Related to Redmine - Defect #13654: Can't set parent issue when issue relations among child i... Closed
Duplicated by Redmine - Feature #14660: Excluding "related to" relation from circular dependency ... Closed
Duplicated by Redmine - Defect #13914: Circular dependency issue when issue dependency is set Closed

History

#1 Updated by Jean-Baptiste Barth almost 7 years ago

  • Category set to Issues
  • Status changed from New to 7
  • Assignee set to Jean-Baptiste Barth
  • Target version set to Candidate for next major release

Agreed, definitely. I'll have a look at it since I already worked on issue relations today.

#2 Updated by Victor Engmark over 6 years ago

"Related to" is reciprocal to itself. In other words, when such a relation is created, there should be a link from both issues to the other one of the relation.

#3 Updated by Christian Zagrodnick over 6 years ago

Victor Engmark wrote:

"Related to" is reciprocal to itself. In other words, when such a relation is created, there should be a link from both issues to the other one of the relation.

That is the case but you could still want to build larger circles A -> B -> C -> A.

#4 Updated by Fares Abdullah about 6 years ago

I had the same problem -

In my case I had an issue, A. I created issue B and set it as related to A. Then I found that B was a duplicate of an existing issue, C, that someone else had created.

I marked B as a duplicate of C, and wanted to relate A to C, and got the "circular dependency" error. I had to manually go and delete the relation between A and B to be able to relate A to C, even though it should not be necessary.

"related to" should allow many different issues related together, as it is not a "dependency".

Cheers and thanks for the great application!

#5 Updated by Jean-Baptiste Barth almost 6 years ago

  • Assignee deleted (Jean-Baptiste Barth)

#6 Updated by Jean-Philippe Lang over 5 years ago

  • Status changed from 7 to New

Assigned issue with no assignee back to New status.

#7 Updated by Leandro Guida almost 5 years ago

Here we are having the same problem.

I have an issue A, which is "father" of the issues B and C. When I try to set that C follows B, it gives me the "circular dependency" message.

#8 Updated by Robin McKenzie almost 5 years ago

+1 "related to" isn't a dependency.

Having the same problem, since we upgraded to the latest version of Redmine.

I've had to advise all our devs to stop using the Related Issues functionality, as this is preventing us setting up tickets with parent/child relationships.

e.g. Create a parent ticket, and two child tickets of this. Attempt to relate the two child tickets - "This relation would create a circular dependency".

Alternatively, create two tickets and relate them to each other. Create another ticket, and then set child A to have this as its parent. Attempt to set child B to have the same parent - "Parent task is invalid".

Would it be possible to get a fix for this prioritised?

#9 Updated by Ralf S. almost 5 years ago

+1 for this ticket from our side to (using V2.3.1)

It would be very nice, if this fix would get high priority for the next release.

#10 Updated by Benjamin Roberts almost 5 years ago

+1 for this issue

Environment:
Redmine version 2.3.0.stable
Ruby version 1.9.3 (i386-mingw32)
Rails version 3.2.13
Environment production
Database adapter Mysql2
Redmine plugins:
no plugin installed

#11 Updated by Luke Purdy almost 5 years ago

+1 for this update.

At the moment I can't create any parent "summary" tasks, for any children who have following dependencies between them (as 4).

It would be helpful if this fix is included as a high priority within the next release.

#12 Updated by Robin McKenzie over 4 years ago

Would it be possible to get some feedback as to whether this is being considered for the next release? It was originally set to "Candidate for next major release" over two years ago...

#13 Updated by Akiko Takano about 4 years ago

+1 for this update.

#14 Updated by Egbert van der Wal almost 4 years ago

How can this still be open when it's such a simple fix?

I applied the attached patch to my Redmine SVN checkout to fix this. Feel free to merge it in. It basically takes the type of relations into account when traversing them and ignores 'copied_to', 'duplicates' and 'relates' relationships as these do not imply any dependency.

#15 Updated by Egbert van der Wal almost 4 years ago

Sorry, this was the incorrect patch. Attached is the correct version. Please remove the previous patch.

#16 Updated by Egbert van der Wal almost 4 years ago

Just a tiny update after reading the Patch page.

The patch I submitted is against revision 13127 of the stable-2.5 branch. I just tested it against trunk, revision 13138 and it also applies cleanly.

#17 Updated by Toshi MARUYAMA almost 4 years ago

  • Duplicated by Feature #14660: Excluding "related to" relation from circular dependency check added

#18 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to deleted (Defect #13914: Circular dependency issue when issue dependency is set)

#19 Updated by Toshi MARUYAMA almost 4 years ago

  • Duplicated by Defect #13914: Circular dependency issue when issue dependency is set added

#20 Updated by James H almost 4 years ago

+1

#21 Updated by Uwe Koloska over 3 years ago

What about the fix for #7320? Shouldn't the tests for r4723 and r5104 detect the problem described here?

#22 Updated by Uwe Koloska over 3 years ago

It looks like related to has a direction!

  • create three tickets 1, 2, 3
  • create relation 1 -> 2
  • create relation 2 -> 3
  • create relation 3 -> 1 gives the circular dependency error
  • create relation 1 -> 3 succeeds
instead of related to you can also use in any combination:
  • duplicates (no error with duplicated by)
  • copied to (no error with copied from)

Since both are really meant to have a direction their's nothing wrong if there is a circle of all duplicates or copied to, but it should definitely not treat all relations the same.

#23 Updated by Uwe Koloska over 3 years ago

attached a test for the current 2.5 branch (but has not changed in trunk) that tests for the following dependencies that should both not be circular:
  • 1->2, 2->3, 3->1 (error)
  • 1->2, 2->3, 1->3 (no error)

#24 Updated by Etienne Rossignon over 3 years ago

+1 to get a fix for this one

#25 Updated by Mischa The Evil over 3 years ago

  • Related to Defect #16818: 'copied_to' shouldn't conflict with other relation types added

#26 Updated by Marco Shima over 3 years ago

+1 to finally get this fixed. Redmine is only partially useful as long as this major bug exists.

#27 Updated by Anton Statutov almost 3 years ago

+1. This definitely needs to be fixed.

#28 Updated by Nayuta Taga over 2 years ago

+1

#29 Updated by Jānis Elmeris over 2 years ago

+1

#30 Updated by Go MAEDA over 2 years ago

r15056 also seems to have fixed this issue.
Now I can make A->B, B->C, C->A relations on Redmine 3.2.0.devel.15056.

#31 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Resolved
  • Target version changed from Candidate for next major release to 3.3.0

Fixed by #13654.
I am setting target version to 3.3.0 because I think it would be better to list this important issue in Changelog.

#32 Updated by Go MAEDA over 2 years ago

  • Related to Defect #13654: Can't set parent issue when issue relations among child issues are present added

#33 Updated by Jean-Philippe Lang over 2 years ago

  • Status changed from Resolved to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Thanks.

#34 Updated by Robin McKenzie almost 2 years ago

Hi, any idea when 3.3.0 will be released?

Also available in: Atom PDF