Feature #1509

Show new issue notes in the activity list

Added by Brian Terlson over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-06-20
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:0.8
Resolution:Fixed

Description

When a user comments on an issue without changing any of its properties, nothing shows up on the activity timeline. If you're not subscribed to the issue, the only way I've found to keep tabs on this is to sort the issues by when it was updated. I think new notes on an issue should show up in the activity timeline even if the issue's properties haven't changed. I could probably write a patch, but it looks like it might be some work so I didn't want to go through the effort unless I knew it would be a worthwhile endeavor :) Plus, it could potentially be a new category of activity rather than being the same as Messages.

show_full_activity.diff Magnifier (1.01 KB) Brian Terlson, 2008-06-20 21:48


Related issues

Related to Redmine - Feature #1030: Adding comments is not an "activity"? Closed 2008-04-10

Associated revisions

Revision 1567
Added by Jean-Philippe Lang over 9 years ago

Display issue notes in the activity view (#1509).

History

#1 Updated by Stephanie Collett over 9 years ago

+1

I am the administrator for Redmine in my organization. We just started a transition to Redmine a couple months ago. This is the number one request I am hearing from a group heavily using the software. I think it would be a great feature!

#2 Updated by Paul Rivier over 9 years ago

It looks like a duplicate of #1373.
If so, please link and close.

#3 Updated by Brian Terlson over 9 years ago

Indeed it is a duplicate. Sorry about that - I searched both in Redmine and with google to check for duplicates, but nothing turned up!

I guess that means +2 ;)

#4 Updated by Brian Terlson over 9 years ago

The patch is actually pretty damn simple. Currently there is a check to make sure that the issue updates only show status updates. If you want to show every issue update, not just when the status changes, apply this diff which simply amounts to removing a condition in the issue query.

#5 Updated by Jean-Philippe Lang over 9 years ago

  • Category set to Issues
  • Status changed from New to Closed
  • Target version set to 0.8
  • Resolution set to Fixed

Issue notes in the activity view added in r1567.

#6 Updated by Go MAEDA almost 3 years ago

  • Related to Feature #1030: Adding comments is not an "activity"? added

Also available in: Atom PDF