Defect #1516

Issue loses custom field values

Added by Thomas Löber over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-06-23
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:0.8
Resolution:Fixed Affected version:

Description

An issue may lose all its custom field values.

Steps to reproduce:
  1. create one required and one non-required issue custom field
  2. create a tracker that uses these two custom fields
  3. create a new issue using the tracker and enter values into both custom fields
  4. when the issue is shown click on update
  5. with (for example) "Firefox DOM Inspector" remove the required custom field from the DOM
  6. submit the form
  7. error message "<<custom field>> can't be blank" appears (which is correct)
  8. enter the ticket id in the search field to reload the page
Result:
  1. the issue's custom fields are blank (and no journal details are written)
Expected Result:
  1. the issue should not have changed

History

#1 Updated by Thomas Löber over 9 years ago

I did a bit more testing and found out that you don't have to remove the required custom field from the DOM: just leave it empty.

#2 Updated by Jean-Philippe Lang over 9 years ago

Confirmed. A fix should be committed soon.

#3 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Target version set to 0.8
  • Resolution set to Fixed

r1592 should fix this problem.
Now if you do not post custom field in your request, no change is made.

#4 Updated by Thomas Löber over 9 years ago

Looks good!

Thanks!

Also available in: Atom PDF