Defect #15190

JS-error while using a global custom query w/ project filter in a project context

Added by Danil Tashkinov about 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:2.3.4
Resolution:Fixed Affected version:2.3.3

Description

Hi,
If I open custom query within a project then I got this error in application.js:120
Uncaught TypeError: Cannot read property 'type' of undefined

I see this error if I use project filter in custom query.

Associated revisions

Revision 12234
Added by Jean-Philippe Lang about 4 years ago

Fixed: JS-error while using a global custom query w/ project filter in a project context (#15190).

History

#1 Updated by Mischa The Evil about 4 years ago

  • Subject changed from Error while open custom query with project in filter to JS-error while using a global custom query w/ project filter in a project context
  • Status changed from New to Confirmed

This message is given because the project filter is not available on project issues lists, only on the cross-project issues list (/issues).
OTOH: the filter and it's values seem to be actually used (correctly!) when using the query in a project context...

I tested this using Opera 12.16, which gives the following message: Unhandled Error: Cannot convert 'filterOptions' to object. Though, these messages does not seem to stop any functionalities of Redmine from working.

Danil, what browser do you use and (how) does the error affect the usability in your case?

#2 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.3.4
  • Resolution set to Fixed

Fixed in r12234.

#3 Updated by Jean-Philippe Lang about 4 years ago

  • Status changed from Resolved to Closed

Merged.

Also available in: Atom PDF