Feature #15289

Recalculate priority of a parent issue automatically after child issue is closed

Added by Florian S. almost 4 years ago. Updated almost 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

A ticket's priority cannot be edited if the ticket has subtasks.

  • subtask a very very urgent
  • subtask b normal
  • subtask c very very low

It seems as the highest priority of a subtask will be passed to the parent issue.

In the case above the parent's priority is very very urgent.

After ticket a and b are closed ticket c remains but the priority of the parent still is very very urgent.

I think recalculating the parent's priority after a ticket of a sub task is finished and using the highest priority of remaining tickets would help much for the daily work...


Related issues

Duplicates Redmine - Defect #5880: Only consider open subtasks when computing the priority o... Closed 2010-07-14

History

#1 Updated by Jaap de Haan about 2 years ago

I fully agree with this idea. Priority is something dynamic. You can have a main task that has a subtask to urgently provide a workaround while another subtask takes care with lower prio of tackling the root cause in a clean way. This happens quite often in practice to us too.

+1 for this!

#2 Updated by Go MAEDA almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing this issue as a duplicate of #5880.

#3 Updated by Go MAEDA almost 2 years ago

  • Duplicates Defect #5880: Only consider open subtasks when computing the priority of a parent issue added

Also available in: Atom PDF