Defect #15377

bundle install --without development test fails

Added by Tod Beardsley almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Rails support
Target version:2.5.0
Resolution:Cant reproduce Affected version:2.4.0

Description

When installing per the instructions at

http://www.redmine.org/projects/redmine/wiki/RedmineInstall

bundler completes without incident. However, I am unable to `rake generate_secret_token` (the next step)

I get the message:

redmine@shawshank ~/redmine-2.4.0 $ rake generate_secret_token
Could not find gem 'database_cleaner (>= 0) ruby' in the gems available on this machine.
Run `bundle install` to install missing gems.

This is because database_cleaner is part of the test section.

Solution: move database_cleaner out of test and into main

Workaround: bundle install --without development # maybe, trying this now.


Related issues

Duplicated by Redmine - Defect #15797: Could not find gem 'database_cleaner (>= 0) x86-mingw32' ... Closed

Associated revisions

Revision 12298
Added by Jean-Philippe Lang almost 5 years ago

Removed database_cleaner dependency (#15377).

History

#1 Updated by Tod Beardsley almost 5 years ago

redmine@shawshank ~/redmine-2.4.0 $ ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [arm-linux-eabihf]
redmine@shawshank ~/redmine-2.4.0 $ rails -v
Could not find gem 'rmagick (>= 2.0.0) ruby' in the gems available on this machine.
Run `bundle install` to install missing gems.

Currently stepping through the remaining missing requirements.

#2 Updated by Mischa The Evil almost 5 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Please head over to the Help forum and post your support request there instead of posting it here as a defect in the tracker.

#3 Updated by Tod Beardsley almost 5 years ago

  • Status changed from Closed to Reopened

It's not a support request (stepping through the rest of the requirements lead to no surprises). The fact of the matter is, the documented installation procedure is incorrect. I'm doing fine, but `bundle install --without development test` leads to a broken installation that needs to be repaired. Not exactly a rewarding OOB experience.

Not to worry, I can provide patches (just not at this moment). I suspect just moving database_cleaner to the main bundler set will do the trick, or, instructing users to install the rails gem first (iirc, Rails also provides database_cleaner).

#4 Updated by Jean-Philippe Lang almost 5 years ago

  • Resolution changed from Invalid to Cant reproduce

rake generate_secret_token runs just fine for me when using bundle install --without development test. I'll remove this dependency anyway as it's no longer needed.

#5 Updated by Jean-Philippe Lang almost 5 years ago

  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.5.0

#6 Updated by Jean-Philippe Lang almost 5 years ago

  • Status changed from Reopened to Closed

#7 Updated by Jean-Philippe Lang almost 5 years ago

  • Duplicated by Defect #15797: Could not find gem 'database_cleaner (>= 0) x86-mingw32' in the gems available on this machine. added

Also available in: Atom PDF