Defect #1744

Em Dash (–) and “ turned in to – with last code update

Added by David Petersen about 9 years ago. Updated almost 6 years ago.

Status:ClosedStart date:2008-08-04
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:Cant reproduce Affected version:0.7.3

Description

We have been running on .7.0 for a while now and finally got around to updating to the newer fixes that have been released for .7.3 When we deployed the changes on our site there where a few wiki pages where characters got all screwed up. em Dash (–) and “ turned in to –. Is there anything in the code changes from .7.0 to .7.3 that would cause this?

History

#1 Updated by Jean-Philippe Lang about 9 years ago

  • Target version deleted (0.7.3)

#2 Updated by Thomas Lecavelier about 9 years ago

When you have migrated, have you recreated your config/database.yml file and forget about utf-8 declaration?

#3 Updated by David Petersen about 9 years ago

Nope it was set to utf8 before and after the upgrade.

#4 Updated by Jean-Philippe Lang about 9 years ago

I can't see what could have caused this problem. No update is done on description fields in the database when upgrading.
Did you dump/import your database for this new deployment ?
Does this problem occur at rendering time or do these characters have been changed in your database ?

#5 Updated by David Petersen about 9 years ago

We did not dump then import the database for the upgrade. Just deployed the new code and ran the migrate command.
Looks like these characters are in the db.

#6 Updated by Mischa The Evil almost 6 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Outdated.

Also available in: Atom PDF