Defect #18223

Table renders wrong if a trailing space is after | symbol

Added by René van Dorst about 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Text formatting
Target version:3.2.0
Resolution:Fixed Affected version:2.5.3

Description

Also mentioned by Stephan Brönnimann in #14038#note-8

Table renders wrong is a space is after | symbol.

| 1.1 | 1.2 |
| 2.1 | 2.2 | <-space here
| 3.1 | 3.2 |
| 4.1 | 4.2 |
1.1 1.2
2.1 2.2
3.1 3.2
4.1 4.2

redmine_18223.diff Magnifier (1.53 KB) Jens Krämer, 2015-08-18 11:36


Related issues

Related to Redmine - Defect #14038: Ordered/unordered lists inside table cell are mangled Reopened

Associated revisions

Revision 14611
Added by Jean-Philippe Lang over 2 years ago

Table renders wrong if a trailing space is after | symbol (#18223).

Patch by Jens Krämer.

History

#1 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from New to Closed

#14038 is still open.

#2 Updated by Toshi MARUYAMA about 3 years ago

  • Related to Defect #14038: Ordered/unordered lists inside table cell are mangled added

#3 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from Closed to New

#4 Updated by @ go2null about 3 years ago

I am not sure this is a defect.

Any character after the | works as a line continuation character to have multi-line text in a cell, or to dynamically create a multi-column table.

With this view, the issue is more that the space is not visible in the browser, so the user doesn't know it there.
However, if you Preview (or after Submit) it is easily spotted and corrected.

#5 Updated by Jens Krämer over 2 years ago

Attached is a patch that fixes this (without breaking the original fix from #14038). Test case included.

#6 Updated by Toshi MARUYAMA over 2 years ago

  • Target version set to 3.2.0

#7 Updated by Jean-Philippe Lang over 2 years ago

  • Subject changed from Table renders wrong is a space is after | symbol. to Table renders wrong if a trailing space is after | symbol
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch committed in r14611, thanks.

Also available in: Atom PDF