Defect #18349

URL not rendered as a link when followed by a line break and another URL

Added by Oleg Fedotkin over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Text formatting
Target version:2.6.1
Resolution:Fixed Affected version:2.3.1

Description

Hello.

I've encountered a problem, related to the redmine formatting. The thing is, that when I try to add issue description (or comment) with the following content:

Any text https://name.domain.com/issues/91243
http://name.domain.com/00boUr-6lA1oXahp/

The first link doesn't seem to appear like a link. It's just a plain text. As far as I can get it, this problem caused by a bug in the WikiFormatting auto_link! method. Speaking more precisely, I think that regex is not completely correct. So, is it really a bug or am I doing something wrong?

My version of redmine is 2.3.1.stable, Postgres 9.3.5, ruby 1.9.3 stable and rails 2.2.2.


Related issues

Duplicated by Redmine - Defect #13726: Link not clickable Closed

Associated revisions

Revision 13592
Added by Jean-Philippe Lang over 3 years ago

Fixed that URLs separated by line break are not rendered as links (#18349).

Revision 13594
Added by Jean-Philippe Lang over 3 years ago

Removed debug messages (#18349).

Revision 13599
Added by Jean-Philippe Lang over 3 years ago

Removed debug messages (#18349).

History

#1 Updated by Toshi MARUYAMA over 3 years ago

  • Category changed from Issues to Text formatting

#2 Updated by Jean-Philippe Lang over 3 years ago

  • Subject changed from Links formatting is broken to URL not rendered as a link when followed by a line break and another URL
  • Status changed from New to Resolved
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.6.1
  • Resolution set to Fixed

Fixed in r13592, thanks for poiting this out.

#3 Updated by Oleg Fedotkin over 3 years ago

Thank you!

#4 Updated by Jean-Philippe Lang over 3 years ago

  • Status changed from Resolved to Closed

Merged.

#5 Updated by Go MAEDA about 3 years ago

Also available in: Atom PDF