Defect #19172

"gem update bundler" suggestion for "`x64_mingw` is not a valid platform"

Added by Lukas Pirl over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Gems support
Target version:3.0.1
Resolution:Fixed Affected version:3.0.0

Description

I just tried to install Redmine 3.0.0 on Debian 7.8 and

bundle install --without development test rmagick

died with

`x64_mingw` is not a valid platform. The available options are: [:ruby, :ruby_18, :ruby_19, :ruby_20, :mri, :mri_18, :mri_19, :mri_20,
:rbx, :jruby, :mswin, :mingw, :mingw_18, :mingw_19, :mingw_20

After I removed all occurrences of x64_mingw from the Gemfile, bundle install completed without an error.

I run ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux].


Related issues

Duplicated by Redmine - Defect #19192: "rake" command is showing error, `x64_mingw` is not a val... Closed

Associated revisions

Revision 14065
Added by Jean-Philippe Lang over 3 years ago

Require bundler >= 1.5.0 (#19172).

Revision 14443
Added by Toshi MARUYAMA about 3 years ago

doc/INSTALL: update requirements Bundler >= 1.5.0 (#19172)

Revision 14444
Added by Toshi MARUYAMA about 3 years ago

Merged r14443 from trunk to 3.1-stable (#19172)

doc/INSTALL: update requirements Bundler >= 1.5.0.

Revision 14445
Added by Toshi MARUYAMA about 3 years ago

Merged r14443 from trunk to 3.0-stable (#19172)

doc/INSTALL: update requirements Bundler >= 1.5.0.

History

#1 Updated by Toshi MARUYAMA over 3 years ago

  • Target version set to 3.0.1

Same output: infamous - `x64_mingw` is not a valid platform..

Could you try this command and give me output?

$ bundle --version
Bundler version 1.7.7

And could you try this command?

$ gem update bundler

#2 Updated by Jonas Götze over 3 years ago

Toshi MARUYAMA wrote:

And could you try this command?

[...]

Thanks - this one was working well for me!

#3 Updated by Toshi MARUYAMA over 3 years ago

":x64_mingw" is defined in bundler 1.4.0.rc.1.
https://github.com/bundler/bundler/blob/master/CHANGELOG.md#140rc1-2013-09-29

add support for the x64-mingw32 platform

https://github.com/bundler/bundler/pull/2590/files#diff-76f6360610f33190a6dd9c84ceb86b91R27

stackoverflow suggests adding check in Gemfile.
Redmine 1.4 uses similar check.
source:tags/1.4.0/config/preinitializer.rb#L9

Bundler did not release 1.4.0, so do we need to suggest using 1.5.0?

Top of Gemfile:

if Gem::Version.new(Bundler::VERSION) < Gem::Version.new('1.5.0')
  abort "Redmine requires Bundler 1.5.0 (you're using #{Bundler::VERSION}).\nPlease update with 'gem update bundler'." 
end

#4 Updated by Toshi MARUYAMA over 3 years ago

  • Subject changed from Redmine 3 on Debian 7.8: `x64_mingw` is not a valid platform to "gem update bundler" suggestion for "`x64_mingw` is not a valid platform"

#5 Updated by Lukas Pirl over 3 years ago

Toshi MARUYAMA wrote:

stackoverflow suggests adding check in Gemfile.

That's what I would have expected from gem/the Gemfile. It would take away a lot of frustration from administrators that are not ultimately comfortable with the Ruby tool chain.

Sorry, I tried to upgrade a production system so I can only check this next time I try it (we had another issue with a incompatible plugin…). But gem update bundler sound reasonable.

#6 Updated by Go MAEDA over 3 years ago

  • Related to Defect #19192: "rake" command is showing error, `x64_mingw` is not a valid platform. added

#7 Updated by Go MAEDA over 3 years ago

  • Related to deleted (Defect #19192: "rake" command is showing error, `x64_mingw` is not a valid platform. )

#8 Updated by Go MAEDA over 3 years ago

  • Duplicated by Defect #19192: "rake" command is showing error, `x64_mingw` is not a valid platform. added

#9 Updated by Jean-Philippe Lang over 3 years ago

  • Category set to Gems support
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Also available in: Atom PDF