Defect #19218

Wrong name for pt-BR in language drop-down

Added by Glaubert Dumpierre about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Translations
Target version:3.0.1
Resolution:Fixed Affected version:3.0.0

Description

After installation does not appear the Portuguese language (Brazilian) "en-us" for selection, only Portuguese of Portugal.

pt-BR.png (27.8 KB) Toshi MARUYAMA, 2015-03-01 15:55

pt-br-lang-name.patch Magnifier (500 Bytes) Go MAEDA, 2015-03-05 16:23


Related issues

Related to Redmine - Patch #13120: Translation in language selection Closed

Associated revisions

Revision 14051
Added by Jean-Philippe Lang about 3 years ago

Wrong name for pt-BR language (#19218).

Patch by Go MAEDA.

History

#1 Updated by Jan Niggemann (redmine.org team member) about 3 years ago

  • Status changed from New to Needs feedback

Do I understand correctly: You only see "en-us" and nothing else in the dropdown?

#2 Updated by Glaubert Dumpierre about 3 years ago

Sorry, my mistake, the correct description would be:

After installation does not appear the Portuguese language (Brazilian) "pt-BR" for selection, only Portuguese of Portugal.

All other languages appear

#3 Updated by Toshi MARUYAMA about 3 years ago

I cannot reproduce.

#4 Updated by Toshi MARUYAMA about 3 years ago

  • Related to Patch #13120: Translation in language selection added

#5 Updated by Go MAEDA about 3 years ago

The format of language names is "english name (native name)" from r13909, but I forgot to fix pt-BR in the patch attatched to #13120.

I wrote a new patch to fix it. Mr. Maruyama, could you please merge it to trunk?

#6 Updated by Jean-Philippe Lang about 3 years ago

  • Subject changed from I can not enable the pt-BR language to Wrong name for pt-BR in language drop-down
  • Status changed from Needs feedback to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch applied in r14051, thanks.

#7 Updated by Toshi MARUYAMA about 3 years ago

Is it correct changing status to "Closed"?
r14051 is not yet merged to 3.0-stable.
And CI server does not have 3.0-stable.

#8 Updated by Jean-Philippe Lang about 3 years ago

  • Status changed from Closed to Resolved

#9 Updated by Jean-Philippe Lang about 3 years ago

  • Status changed from Resolved to Closed

#10 Updated by Toshi MARUYAMA about 3 years ago

Toshi MARUYAMA wrote:

And CI server does not have 3.0-stable.

Thank you for adding 3.0-stable on CI server.
But 3.0-stable on CI server does not have SQLServer environment.

Also available in: Atom PDF