Feature #22109

REST API to get a list of the activites

Added by Vanessa Martinez over 3 years ago. Updated over 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:REST API
Target version:-
Resolution:

Description

Hi,

I would like to enrich a time recording solution to be able to select a ticket from redmine.
Therefore it would be great to have a REST API like the time entries with input variables for:
- User
- Date
- Time
- Project

to retrieve all the tickets the user was working on this specific date. Time and project would be nice additional filter values.

Regards, Vanessa


Related issues

Related to Redmine - Feature #14872: Activities REST API New

History

#1 Updated by Vanessa Martinez over 3 years ago

At least this would reflect the informations that are presented in the "Activity" for a project.

#2 Updated by Vanessa Martinez over 3 years ago

  • Status changed from New to Resolved

#3 Updated by Toshi MARUYAMA over 3 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Duplicate of #14872.

#4 Updated by Toshi MARUYAMA over 3 years ago

#5 Updated by Chris Burgess over 2 years ago

Please re-open this issue.

#22109 proposes exposing the existing Redmine Activity view via an API.
#14872 proposes introducing a new entity for lightweight notifications from systems external to Redmine. It proposes the name "Activities" which already has a meaning in Redmine context (any Redmine entity modified within a date range).

These are not duplicates, but the confusing terminology on the latter ticket makes them appear so.

#6 Updated by Toshi MARUYAMA over 2 years ago

#7 Updated by Toshi MARUYAMA over 2 years ago

#8 Updated by Toshi MARUYAMA over 2 years ago

  • Status changed from Closed to New
  • Resolution deleted (Duplicate)

Also available in: Atom PDF