Defect #22305

Highlighting of required and read-only custom fields broken in Workflow editor.

Added by Serghei Zagorinyak over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.1.5
Resolution:Fixed Affected version:3.1.4

Description

1. Go to Administration/Workflow
2. Open Fields permissions tab
3. Add some read-only and required fields in the Standard fields section
4. Add some read-only and required fields in the Custom fields section
5. Save changes

Read-only and required fields in Standard fields section are highlighted with grey and red rescpectively.
Read-only and required fields in Custom fields section are not highlighted.

defect-22305.png (6.91 KB) Go MAEDA, 2016-03-27 05:31

defect-22305.diff Magnifier (1.75 KB) Go MAEDA, 2016-03-27 06:32


Related issues

Related to Redmine - Defect #19580: "Required" and "Read-only" rules on "Fields Permissions" ... Closed

Associated revisions

Revision 15293
Added by Jean-Philippe Lang over 2 years ago

Highlighting of required and read-only custom fields broken in Workflow editor (#22305).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA over 2 years ago

Confirmed in trunk (3.2.1.devel.15287).

Caused by a wrong class name for td element.

          <td class="[&quot;required&quot;]">
            <select name="permissions[1][5]" id="permissions_1_5"><option value=""></option>
<option value="readonly">Read-only</option>
<option selected="selected" value="required">Required</option></select>
            <a href="#" class="repeat-value">&#187;</a>
          </td>

#2 Updated by Go MAEDA over 2 years ago

  • Related to Defect #19580: "Required" and "Read-only" rules on "Fields Permissions" screen are not colored added

#3 Updated by Go MAEDA over 2 years ago

  • File defect-22305.diffMagnifier added
  • Target version set to 3.1.5
  • Affected version changed from 3.2.1 to 3.1.4

Here is a patch to fix this issue: defect-22305.diff

#4 Updated by Jean-Philippe Lang over 2 years ago

  • Status changed from Confirmed to Resolved
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Committed, thanks.

#5 Updated by Jean-Philippe Lang over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF