Defect #2550

Project overview page shows disabled trackers

Added by Brad Beattie almost 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:2009-01-20
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:ProjectsEstimated time:0.25 hour
Target version:0.9.0
Resolution:Fixed Affected version:

Description

Create a project and disable all but one tracker (e.g. support and feature disabled, bug enabled). Note that the page overview will still list the number of support and feature tickets ("0 open on 0" for both). These shouldn't be displayed at all, yeah?

app/views/projects/show.rhtml, line 24

Associated revisions

Revision 2311
Added by Jean-Philippe Lang over 8 years ago

Ignore archived subprojects in Project#rolled_up_trackers (#2550).

History

#1 Updated by Jean-Philippe Lang almost 9 years ago

I think you have subprojects with this tracker enabled, don't you?

#2 Updated by Brad Beattie almost 9 years ago

Jean-Philippe Lang wrote:

I think you have subprojects with this tracker enabled, don't you?

Mm... true. Archived, but there. Not sure if archived projects should affect this, but that's a design choice, not a bug, eh?

#3 Updated by Jean-Philippe Lang almost 9 years ago

Not sure if archived projects should affect this, but that's a design choice, not a bug, eh?

It's more like a bug. I'll fix it.

#4 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from New to Closed
  • Target version set to 0.9.0
  • Resolution set to Fixed

Fixed in r2311.

Also available in: Atom PDF