Feature #298

Project to subproject relationship

Added by Doug Renn over 10 years ago. Updated about 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Projects
Target version:-
Resolution:Duplicate

Description

I suggest changing the project to sub-project relationship from one-to-many to a many-to-many relationship such that
a sub-project could belong to more than one project.


Related issues

Duplicates Redmine - Feature #5283: Allow more than one parent project i.e. share subprojects New 2010-04-09

History

#1 Updated by Philippe Lachaise about 10 years ago

Having a visual representaion of such relationhips would be a
big help.
With the current implementation listing projects like this would
already be a big plus :

project_1
sub-project-1.1
sub-project-1.2
sub-sub-project-1.2.1
sub-project-1.3
project_2
sub-project-2.1

#2 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Would add too much complexity when things like roles inheritance will be implemented.

#3 Updated by Richard Pecl over 8 years ago

  • Status changed from Closed to Reopened

Could you reconsider this decision?
Such feature is really needed. We have many sub-projects shared between many projects.

#4 Updated by Thomas Pihl over 8 years ago

If they are shared, are they then really subprojects? Sounds more like they are parallell projects with relations to many other projekts.

/T

#5 Updated by Richard Pecl over 8 years ago

They are subprojects.
E.g.: we have communication library, this library is used in two different projects. We need to show issues in communication library in both projects, and on each project there must be clear indication, that it depends on the communication library.
I know there is a workaround filtering issues on multiple projects, but that solves just part of the problem and is totally out of project-subproject user-friendly concepts.

Could somebody designate what Redmine functionality could be affected/must be changed when implementing this feature? Where are sub-projects processed and shown, what are the issues, drawbacks?

As roles inheritance has been mentioned - is that implemented already? I don't think it is necessary to have role inheritance if that breaks possible sub-project sharing.

#6 Updated by Brian Lindahl over 6 years ago

I've remarked on how we solve the problem of shared components in #5283. In my opinion, this is a better way of handling shared components than allowing subprojects to have multiple parents. It better represents whats truly going on, especially when you bring SCM into the picture.

#7 Updated by Etienne Massip over 6 years ago

  • Category set to Projects

#8 Updated by Tomislav ParĨina over 3 years ago

This feature has been opened for long time, and was requested many times. It would be great if it would be implemented.

Duplicates that I could find:

#9 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicated by deleted (Feature #5283: Allow more than one parent project i.e. share subprojects)

#10 Updated by Toshi MARUYAMA about 3 years ago

  • Status changed from Reopened to Closed
  • Resolution changed from Wont fix to Duplicate

Close as duplicate of #5283.
#5283 has more discussions.

#11 Updated by Toshi MARUYAMA about 3 years ago

  • Duplicates Feature #5283: Allow more than one parent project i.e. share subprojects added

Also available in: Atom PDF