Defect #3133

Internal error(500) on issue update

Added by Yuval Hager over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:2009-04-07
Priority:UrgentDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:

Description

I have redmine 0.8.3 installed using phusion passenger. It was working fine, but all of the sudden I get an internal error everytime I try to update an issue.

The virtual host file:

LoadModule passenger_module /var/lib/gems/1.8/gems/passenger-2.1.3/ext/apache2/mod_passenger.so
PassengerRoot /var/lib/gems/1.8/gems/passenger-2.1.3
PassengerRuby /usr/bin/ruby1.8
PassengerLogLevel 4
#RailsSpawnMethod conservative

<VirtualHost X.X.X.X:80>
  ServerName dev.example.com
  ServerAlias redmine.example.com
  DocumentRoot /usr/local/redmine/public

  CustomLog /var/log/httpd/bytes bytes
  CustomLog /var/log/httpd/log combined
  ErrorLog /var/log/httpd/error.log

  <Directory /usr/local/redmine/public>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
  </Directory>
</VirtualHost>

# redirect old redmine installation to new
Listen 3389
<VirtualHost X.X.X.X:3389>
  redirect 301 / http://dev.example.com/
</VirtualHost>

My apache error log shows:

  Forwarding /issues/edit/1845 to PID 12195
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.332 ]:
  Client 0x9c432d8: received message: ['get', 'app_root', '/usr/local/redmine-0.8', 'lower_privilege', 'true', 'lowest_user', 'nobody', 'environment', 'prod
uction', 'spawn_method', 'smart-lv2', 'app_type', 'rails', 'framework_spawner_timeout', '-1', 'app_spawner_timeout', '-1', 'max_requests', '0', 'memory_limi
t', '200', 'use_global_queue', 'false', 'stat_throttle_rate', '0', 'restart_dir', '']
[ pid=12175 file=Application.h:426 time=2009-04-07 08:54:48.344 ]:
  Application 0x9c43a38: created.
[ pid=12183 file=Hooks.cpp:437 time=2009-04-07 08:54:48.345 ]:
  Forwarding /news to PID 12201
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.359 ]:
  Client 0x9c42680: received message: ['get', 'app_root', '/usr/local/redmine-0.8', 'lower_privilege', 'true', 'lowest_user', 'nobody', 'environment', 'prod
uction', 'spawn_method', 'smart-lv2', 'app_type', 'rails', 'framework_spawner_timeout', '-1', 'app_spawner_timeout', '-1', 'max_requests', '0', 'memory_limi
t', '200', 'use_global_queue', 'false', 'stat_throttle_rate', '0', 'restart_dir', '']
[ pid=12175 file=Application.h:426 time=2009-04-07 08:54:48.372 ]:
  Application 0x9c440b0: created.
[ pid=12190 file=Hooks.cpp:437 time=2009-04-07 08:54:48.372 ]:
  Forwarding /projects/activity to PID 12204
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.633 ]:
  Client 0x9c432d8: received message: ['close', '0']
Error during failsafe response: closed stream
(originally closed stream)
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.771 ]:
  Client 0x9c42a70: received message: ['close', '0']
[ pid=12184 file=Hooks.cpp:510 time=2009-04-07 08:54:48.771 ]:
  Backend process 12195 did not return a valid HTTP response. It returned no data.
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.772 ]:
  Client 0x9c42a70: received message: ['get', 'app_root', '/usr/local/redmine-0.8', 'lower_privilege', 'true', 'lowest_user', 'nobody', 'environment', 'prod
uction', 'spawn_method', 'smart-lv2', 'app_type', 'rails', 'framework_spawner_timeout', '-1', 'app_spawner_timeout', '-1', 'max_requests', '0', 'memory_limi
t', '200', 'use_global_queue', 'false', 'stat_throttle_rate', '0', 'restart_dir', '']
[ pid=12184 file=Hooks.cpp:437 time=2009-04-07 08:54:48.772 ]:
  Forwarding /500.shtml to PID 12195
Error during failsafe response: closed stream
(originally No route matches "/500.shtml" with {:method=>:get})
[ pid=12175 file=ApplicationPoolServerExecutable.cpp:479 time=2009-04-07 08:54:48.776 ]:
  Client 0x9c42a70: received message: ['close', '1']
[ pid=12184 file=Hooks.cpp:510 time=2009-04-07 08:54:48.776 ]:
  Backend process 12195 did not return a valid HTTP response. It returned no data.

This is quite urgent for me - I hope it is fine to set the priority as such...

History

#1 Updated by Jean-Baptiste Barth over 8 years ago

IMHO you should post this message in the forum, the "Issue" page lists known (and described!) issues or feature requests.
Anyway, if you want some help, you should provide your redmine logs (you can find them in YOUR_REDMINE_DIRECTORY/log) and provide all the infos requested here (even if it's not a bug, you may have config problem and we need to have infos about your environment)

#2 Updated by Yuval Hager over 8 years ago

  • Status changed from New to Resolved

This was caused by a plugin - someone else installed it and I didn't know. Sorry for the cruft.

#3 Updated by Yuval Hager over 8 years ago

by the way, there was nothing in the production.log, otherwise I would have posted it too. Is there a way to enable it or increase verbosity? I already have config.log_level = :debug in my environment.rb

#4 Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from Resolved to Closed
  • Affected version (unused) deleted (0.8.3)
  • Resolution set to Invalid
  • Affected version deleted (0.8.3)

Also available in: Atom PDF