Defect #3777

Long wiki pages drop text when edited

Added by Lars Erik Gullerud about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:2009-08-25
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:0.8.3

Description

When editing long wiki pages, text "disappears" from the end of the document. This seems to be caused by the fact that Redmine uses datatype "text" (at least in MySQL) to store wiki page contents. Pages exceeding 65535 characters are truncated.

This should probably be changed to MEDIUMTEXT or LONGTEXT or similar, or the system should as a minimum give the user a warning (right now, submissions of changes to a wiki page are accepted and text is simply silently discared from the end of the document).


Related issues

Duplicates Redmine - Defect #1071: Wiki/News/Documents truncate contents to 64K in MYSQL Closed 2008-04-17

History

#1 Updated by Mischa The Evil about 8 years ago

  • Category deleted (Wiki)
  • Resolution set to Duplicate

Closed as a duplicate of issue #1071.

#2 Updated by Mischa The Evil about 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF