Feature #381

general wiki for the whole site

Added by Valdis Pornieks almost 11 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Wiki
Target version:-
Resolution:

Description

many issues are not connected with a single project, like HowTo's, so it would be nice to have a separate wiki for the
whole redmine site.


Related issues

Duplicates Redmine - Feature #1040: Global wiki Reopened 2008-04-10

History

#1 Updated by Ele Mental over 10 years ago

We use redMine in our organization and its shared between mutliple
teams. We have 2 development teams and an IT team. it would
be nice to allow each of these teams to have a global News,
Documents, Wiki, Files, Activity, Roadmaps that show only the
projects in their scope.

#2 Updated by David Petersen over 10 years ago

It almost seems like making "redmine" a "master
root" project with all the real project in redmine as subproject
of it would be exactly what is needed. Would allow you too turn
on and off the different "parts" of the project. You
could also be able to use that "master root" project
to get a calendar view of every project in redmine.

#3 Updated by Cristian Molina over 10 years ago

Yes, me too, idem with other modules like news.
The alternatives that I can think is create a special project
for 'Others' general things or create a superProject and all
projects inherits from it.

#4 Updated by Maxim Krušina over 10 years ago

I agree, but not only Wiki. I think it should be great to have
global: * News * Documents * Wiki * Files

#5 Updated by Derek Montgomery over 10 years ago

That would be indeed really sweet, along with a global forums
that could gather all the projects specific ones into one commun
page.

#6 Updated by Gunars Grundstoks over 10 years ago

Yes, General Wiki for all Redmine site would be very, very useful.
So, Wiki per project, and Wiki for all Redmine.

#7 Updated by Alexandre Garino almost 11 years ago

+1

IMHO a global wiki is a must have to reference coding guidelines,
...

#8 Updated by Igor Rafael over 9 years ago

+1 It's very important.

#9 Updated by Paul Rivier about 9 years ago

David Petersen wrote:

It almost seems like making "redmine" a "master
root" project with all the real project in redmine as subproject
of it would be exactly what is needed. Would allow you too turn
on and off the different "parts" of the project. You
could also be able to use that "master root" project
to get a calendar view of every project in redmine.

Yes, I really agree. Redmine projects could be organized in a tree with a single common root, being the global project.

#10 Updated by Andrew Chaika about 9 years ago

Paul Rivier wrote:

Yes, I really agree. Redmine projects could be organized in a tree with a single common root, being the global project.

After in Redmine was added support for unlimited project nesting many things have changed if you use one "master root" project:
  • There is no need to use "Overral Activity", "All Issues". It was uncomfortable for me to view all issues I was needed to click on all project and then on all issues, now I just click on Main/Global project.
  • When using roles inheritance plugin or patch it's possible to add global roles for some users
  • As you say it's possible to make global/main News, Wikis, etc.

#11 Updated by Paul Rivier about 9 years ago

Andrew Chaika wrote:

(...) if you use one "master root" project:

Yes, and I think we should go even further, and have by default (IOW as a migration) a single root project. Just any project would be a subproject of that one.

#12 Updated by Tim Aleinikoff about 9 years ago

I think will be better to add function "share wikis page" for selected projects. It will be more useful, than only one general wiki.
In my project i use 2 trees of projects - vendors/products and client/projects for organize issues, wikis and others.

#13 Updated by Michael Sanders about 8 years ago

I'm in the same boat.
I want to write some How-to guides for handling the workflow that I have meticulously planned for my team.
However, I do not feel that putting it under one of the projects is proper, as opposed a general wiki that allows me to cover subjects that affect Redmine or all of the projects.

#14 Updated by Ryan Rangel almost 8 years ago

+1

#15 Updated by Željko Trogrlić almost 8 years ago

+1, can be used for
  • organizational issues
  • common technical topics

#16 Updated by Toshi MARUYAMA over 7 years ago

  • Category set to Wiki

#17 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Closed

Closing as a duplicate of #1040.

Also available in: Atom PDF