Defect #4025

Popup Calendar showing a date twice, on different weekdays

Added by William Knak about 8 years ago. Updated almost 5 years ago.

Status:ClosedStart date:2009-10-13
Priority:NormalDue date:
Assignee:Holger Just% Done:

0%

Category:UI
Target version:-
Resolution: Affected version:

Description

Attatched a screenshot, showing october, 17 on saturday AND sunday.

-- Redmine 0.8.3.stable (MySQL)

redmine-popup-calendar-bug.PNG - Redmine popup calendar showing a date twice (12.7 KB) William Knak, 2009-10-13 21:47

calendar_problem.jpg - Calendar Problem 09/10 repeat (19.7 KB) Rodrigo Guerrero, 2009-10-16 15:06

outubro-2010.png - Calendar bug at october after DST change. (8.82 KB) Guilherme Schneider, 2010-10-18 15:44


Related issues

Duplicated by Redmine - Defect #6712: Problem with Calendar Closed 2010-10-20
Duplicated by Redmine - Defect #6726: Day of the week is wrong Closed 2010-10-22

History

#1 Updated by Rodrigo Guerrero about 8 years ago

Hi, I have the same problem, but with 09/10

#2 Updated by rafael mascayano about 8 years ago

The same problem, but with 10/10. RedMine v0.8.4

#3 Updated by Eric Davis about 8 years ago

It's working for me on trunk with English. Could this be a bug in the calendar's i18n?

#4 Updated by Guilherme Schneider about 7 years ago

It happend to me too, here in Brazil. See attachment (from the redmine site, version 1.0.2 I guess?)
It must be related to DST (Daylight saving time), because here in Brazil, the DST begun at October 17th at midnight (the clock goes back to October 16th at 11:00 PM.
I found out that this bug has been resolved in JSCal2-1.8, see here: http://www.dynarch.com/projects/calendar/download/1.8/

#5 Updated by Guilherme Schneider about 7 years ago

Actually, the clock went forward to 1:00 AM of October 17th. We were at GMT-3 and now it is GMT-2.

#6 Updated by Holger Just about 7 years ago

  • Assignee set to Holger Just

I can not reproduce the bug on either Redmine Trunk, nor the redmine.org Redmine. even if I set the language to Português (Brazil) and the timezone to (GMT -03:00) Brasilia. Everything looks right.

Could you please state exactly under which circumstances and which user settings you observe the bug?

#7 Updated by Guilherme Schneider about 7 years ago

Do you have DST enabled?
I've tested on Windows (XP and 7) and with Firefox 3.6.10, IE 7 and 8, on different computers. All have this issue.

#8 Updated by Holger Just about 7 years ago

  • Affected version (unused) changed from 0.8.3 to devel
  • Affected version deleted (0.8.3)

Okay found (and reproduced) it. As Javascript is client side, you have to actually set your client time zone. D'uh... The issue is independent of the selected language in Redmine (tested with English, German and Portuguese (Brazil)). It is only dependent on the timezone configured on the client (browser).

#9 Updated by Holger Just about 7 years ago

I have a patch at http://github.com/meineerde/redmine/commit/aaede7f75501c6314328fbf50f776f162346e81c. This one fixes the issue for me. Please check it.

The essence of the patch is, to use 12:00:00 as a reference time for dates instead of 00:00:00. Thus, there can't be any disambiguity on the date (at least, if there is no DST rule somewhere in the world where they change time at noon).

@Eric: Once this is confirmed, I'm going to send you a pull request.

#10 Updated by Guilherme Schneider about 7 years ago

The patch did work. Thanks!

#11 Updated by Holger Just about 7 years ago

@Eric, I sent you a pull request 3 days ago. Could you commit this one please?

#12 Updated by Vagner Santos about 6 years ago

+1

#13 Updated by Fernando Silveira about 5 years ago

+1

I'm using Redmine 2.0.3.stable and 1.4.4.stable and both have the same bug. After applying the patch from Holger (https://github.com/meineerde/redmine/commit/aaede7f75501c6314328fbf50f776f162346e81c) the bug is gone. Can someone PLEASE commit his pull request?

Holger, could you please ask someone you know to apply your commit? Maybe you could assign this issue to the committer, I don't know.

#14 Updated by Filou Centrinov almost 5 years ago

I couldn't reproduce the problem for Oct 2009/2010 neither on v2.2.1 nor v2.3. Even when the week is starting on Sunday or the time zone is Brasilia everything is fine for me. May it's already fixed?

#15 Updated by Daniel Felix almost 5 years ago

  • Status changed from New to Resolved

Well this issue isn't reproduce able and already fairly outdated.
The library version for the date picker changed various times. I think this is already resolved.

I'm closing this issue. Just reopen if I'm wrong.

#16 Updated by Toshi MARUYAMA almost 5 years ago

  • Status changed from Resolved to Closed

#17 Updated by Daniel Felix almost 5 years ago

Thanks for correction. I missclicked to resolved. :-)

Also available in: Atom PDF