Feature #421

Impersonate user feature

Added by Marc Champion about 12 years ago. Updated over 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:

Description

I really like the "impersonation" feature in project/open where an admin can impersonate other users in order
to test their environment. In redmine I have
to keep a list with user's passwords and forbid them to change it.


Related issues

Related to Redmine - Feature #18609: Elevate to admin mode for authorized user instead of alwa... New
Duplicated by Redmine - Feature #12119: Add a "View as ..." feature for administrator to make wor... Closed
Duplicated by Redmine - Feature #7693: "Log In As" for Admins Closed 2011-02-23

History

#1 Updated by Cassiano Monteiro over 8 years ago

+1!

This is very useful when you have lots of people with different permissions using Redmine. Every time someone canĀ“t do something, I have to go there and ask him to show me, so I can figure out what permission is missing.

#2 Updated by T. Kopetzky over 7 years ago

+1!

That would be really helpful when adding and defining new roles like a product manager.

A work-around would be having a special test user with internal authentication and assigning him to different roles. But if you need to test different users with different rights - as mentioned above - this approach is falling short.

#3 Updated by William Conley over 7 years ago

+1

I recently built this feature for an OSCommerce installation and find it Very Useful. Eventually I'll build it for Redmine (I was here checking to see if redmine has it already ...). It would be very cool if someone built it ... first.

#4 Updated by Jan Niggemann (redmine.org team member) about 7 years ago

Hi William, any progress on this? It would be really cool...

#5 Updated by William Conley about 7 years ago

Nope. No time as yet. But I've needed it a couple times. Had to settle for "assigning" the Issue to the person in question instead of "creating the issue" in their login for them. For now.

The OSCommerce one took only a few hours to perfect, but I have not begun this one. Yet.

Last thing I built (needed!!) was a daily email showing all issues that were "out of line"

It shows items beyond due date. Also beyond our service level (# of days based on start date and tracker). It checks the selected tracker and our present response time for that tracker, which is renamed service level, and compares to see if it is "beyond" the response time. Lists those beyond.

We also modified "Priority" to which we've added "HOLD" and "Question for client" (the daily email ignores these two priorities, since we are waiting for the client and have nothing to do).

Sectioned by Tracker, then sorted by Priority and Start date (descending, of course), we now have a daily email to tell me who is and isn't keeping up with their workload. And whether our Approx Response Times require adjustment! (Eventually, it'll just be calculated instead and adjusted by this daily process, but that's down the road!)

#6 Updated by Jan Niggemann (redmine.org team member) about 7 years ago

William Conley wrote:

Nope. No time as yet. But I've needed it a couple times.

Dang, just today I'd have needed this a couple of times...

The OSCommerce one took only a few hours to perfect, but I have not begun this one. Yet.

I'm not fluent in Ruby / RoR, otherwise I could have contributed.

Last thing I built (needed!!) was a daily email showing all issues that were "out of line"

Isn't there a rake task for this?

Sectioned by Tracker, then sorted by Priority and Start date (descending, of course), we now have a daily email to tell me who is and isn't keeping up with their workload. And whether our Approx Response Times require adjustment! (Eventually, it'll just be calculated instead and adjusted by this daily process, but that's down the road!)

OK, that's more than the default rake task does...

#7 Updated by Moritz Koehler almost 5 years ago

Here is a Plugin that works for me.
I use Redmine 2.6.

https://github.com/leonko/redmine_pretend

#8 Updated by James H over 4 years ago

The easiest thing for me was:

Make "NPC" users (i named them according to their respective position or role) and have the same SUPER SIMPLE password for all of them (i also changed the password rules to accomodate for an even simpler password before changing the rules back).
Make changes as an admin. If i need to test a feature and I need to see the view as a certain role... I log in as that role/user and do what I need. Log back in as admin to make more changes. etc.

I also have these members set up in a project like real users might be set up in a real project. This helps me to create an analogous environment to test similar situations and try to reproduce issues.

This is almost as easy as using some sort of "impersonate" feature, and to me, it is more definitive flexible and error-free (from a data standpoint).

I would advise against logging into other actual users' accounts for testing... but i guess you do with what you have

#9 Updated by William Conley over 4 years ago

James H wrote:

The easiest thing for me was:

Make "NPC" users ...

In my case this is not helpful as we don't always want this as a "fake" user, sometimes we want it as a real user. For instance: I have a client who likes to pay with Paypal outside our commerce system. So I have to log in to the system and enter a payment as that client as if he made the payment by check, and then log out as the client and log in as Admin and record the arrival of the money.

Unusual circumstances like this will always occur. So we have an Impersonate button in the accounting system to allow me to override the system and log in as that specific user.

It's also helpful for walking through a purchase with a client and validating what they see in our systems. You can't really tell a client to click on the bottom link they see if you can't see the same list they are seeing.

#10 Updated by Toshi MARUYAMA over 4 years ago

  • Related to Feature #18609: Elevate to admin mode for authorized user instead of always working at admin level added

#11 Updated by Go MAEDA almost 3 years ago

#12 Updated by JW Fuchs over 2 years ago

+1

This would be a very useful feature!

Also available in: Atom PDF