Defect #6759

rdm-mailhandler does not have a port option, fails with port forwarding

Added by Stephanie Collett about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:2010-10-27
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email receiving
Target version:-
Resolution:Wont fix Affected version:1.0.2

Description

In our environment, applications use port forwarding to avoid using root to start up web services. Port 80 and 443 are forwarded to higher port numbers. This setup does not work with the rdm-mailhandler because it assumes the port number. I created a patch to fix this. The attached patch adds a port option to the rdm-mailhandler.

0170-Add-port-option-to-mail-handler.-Fixes-issue-with-po.patch Magnifier (2.6 KB) Stephanie Collett, 2010-10-27 20:46

History

#1 Updated by Felix Schäfer about 7 years ago

Doesn't protocol://host:port/path work with the mail handler?

#2 Updated by Stephanie Collett about 7 years ago

  • Status changed from New to Resolved

Ah, yes, that works too. I'm not sure why I thought that option wasn't working. I revisited it and have confirmed host:port works fine. I must have been conflating it with other issues now resolved. Thanks.

#3 Updated by Holger Just about 7 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Wont fix

Also available in: Atom PDF