Defect #6810

Problem to access Users page

Added by Rogério Carrasqueira almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:2010-11-03
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:1.0.3

Description

Hi!

I'm trying to install the Redmine 1.0.3 on Ubuntu using Apache 2.x with Mongrel, and after follow the instructions I tried to access the users page to create some accounts. So on acess this the error 500 page appeared and on the log the following information was reported:

ActionView::TemplateError (wrong number of arguments (2 for 0)) on line #21 of app/views/users/index.rhtml:
18: <div class="autoscroll">
19: <table class="list">        
20:   <thead><tr>
21:     <%= sort_header_tag('login', :caption => l(:field_login)) %>
22:     <%= sort_header_tag('firstname', :caption => l(:field_firstname)) %>
23:     <%= sort_header_tag('lastname', :caption => l(:field_lastname)) %>
24:     <%= sort_header_tag('mail', :caption => l(:field_mail)) %>

    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:158:in `warn_syntax_deprecation!'
    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:158:in `interpolate_without_deprecated_syntax'
    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:153:in `gsub'
    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:153:in `interpolate_without_deprecated_syntax'
    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n/backend/base.rb:46:in `translate'
    /var/lib/gems/1.8/gems/i18n-0.4.2/lib/i18n.rb:160:in `t'
    lib/redmine/i18n.rb:15:in `l'
    app/helpers/sort_helper.rb:231:in `sort_header_tag'
    app/views/users/index.rhtml:21:in `_run_rhtml_app47views47users47index46rhtml'
    app/controllers/users_controller.rb:49:in `index'
    /usr/lib/ruby/1.8/mongrel/rails.rb:76:in `process'
    /usr/lib/ruby/1.8/mongrel/rails.rb:74:in `synchronize'
    /usr/lib/ruby/1.8/mongrel/rails.rb:74:in `process'
    /usr/lib/ruby/1.8/mongrel.rb:159:in `process_client'
    /usr/lib/ruby/1.8/mongrel.rb:158:in `each'
    /usr/lib/ruby/1.8/mongrel.rb:158:in `process_client'
    /usr/lib/ruby/1.8/mongrel.rb:285:in `run'
    /usr/lib/ruby/1.8/mongrel.rb:285:in `initialize'
    /usr/lib/ruby/1.8/mongrel.rb:285:in `new'
    /usr/lib/ruby/1.8/mongrel.rb:285:in `run'
    /usr/lib/ruby/1.8/mongrel.rb:268:in `initialize'
    /usr/lib/ruby/1.8/mongrel.rb:268:in `new'
    /usr/lib/ruby/1.8/mongrel.rb:268:in `run'
    /usr/lib/ruby/1.8/mongrel/configurator.rb:282:in `run'
    /usr/lib/ruby/1.8/mongrel/configurator.rb:281:in `each'
    /usr/lib/ruby/1.8/mongrel/configurator.rb:281:in `run'
    /usr/lib/ruby/1.8/mongrel/command.rb:212:in `run'

Rendering /mnt/home/redmine/rails_app/redmine-1.0.3/public/500.html (500 Internal Server Error)

Related issues

Duplicates Redmine - Defect #6784: Redmine not working with i18n gem 0.4.2 Closed 2010-11-01

History

#1 Updated by Holger Just almost 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (Jean-Philippe Lang)
  • Priority changed from Urgent to Normal
  • Resolution set to Duplicate

Redmine is incompatible with i18n >= 0.4.2 currently. Remove any version of the i18n gem >= 0.4.2.

Thus closing as duplicate of #6784.

Also available in: Atom PDF