Feature #7007

MySQL Field size for large text fields

Added by Nathan Rijksen over 8 years ago. Updated almost 4 years ago.

Status:ClosedStart date:2010-11-30
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Duplicate

Description

I noticed that the database design for redmine used TEXT type for multiple fields that can contain large amounts of data, particularly the "description" field in the "issues" table and the "notes" field in the "journals" table. These fields in my opinion should really be given the MEDIUMTEXT type as reporters / commenters can often paste in large amounts of data (such as logs). that will easily exceed the size limit of 64kb which TEXT imposes.

I know that the sensible thing to do here would be for the person to simply add these logs as an attachment but you can not always expect people to be sensible, especially if you work with people that are not very technical and are simply reporting some bugs to you in a way you explained them to (which, as you might have guessed, is what we do at my work).

I've personally already updated my DB to use MEDIUMTEXT but I thought I'd report it here as I think it's in the interest of redmine to have it on that by default.


Related issues

Duplicates Redmine - Feature #19869: Consider increasing the size limit of description and not... Closed

History

#1 Updated by Go MAEDA almost 4 years ago

  • Duplicates Feature #19869: Consider increasing the size limit of description and note columns for tickets added

#2 Updated by Go MAEDA almost 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as duplicate of #19869.
Although this issue is much older, #19869 has watchers.

Also available in: Atom PDF