Patch #717

lang/ja: problem --> ticket

Added by chris mcharg over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:2008-02-22
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Translations
Target version:-

Description

The current (r1168) ja localization translates "Issue" as 問題 . I feel that 問題 (problem) is too limiting, given that Redmine can be setup to track anything.

For example, I might want to track "Ideas" for my project. An Idea would not usually be classed a 問題.

I propose to replace all instances of 問題 with チケット (ticket), and the attached patch does so.

I have confirmed this with two Japanese speakers.

ja-problem-to-ticket.patch Magnifier (10.6 KB) chris mcharg, 2008-02-22 17:06

History

#1 Updated by Satoru KURASHIKI over 9 years ago

hi,

I have tranlated that word. I think that the word "問題" is NOT the best too, and
agree that "Redmine can be setup to track anything", but:

1. The word "Issue" is not "Ticket". And I feel that the term "チケット" is not mature,
used mainly among IT early adopters, software development venture companies, and so on.

2. I select the word from general translation of "Issue Tracking(問題管理/課題管理)",
because these words might be acceptable for managers in Japanese company (than "チケット").

I think that "問題" must be replaced, but I'm not sure "チケット" is it... what do you think about these?

#2 Updated by Yasushi SHOJI over 9 years ago

Hi all,
Sorry to be jump in. please ignore if I'm off the point.

the point is that we don't have one to one representative word for "issue" in Japanese, and the word 問題 is too limited. I believe we all agree on this.

now let me just start a brainstorm. I'd add a few idea:

  • keep it as it is.
  • make it customizable.
  • use イシュー as it is (the worst idea I've got :-p)
  • change English version to ticket so that we can use チケット.

to counterpart the given points are:

1) we write one issue on a ticket, so it should be ok to use a ticket and an issue interchangeably. (we do that while we are talking, don't we?)

2) a) managers nor non-tech workers don't think clicking the tab labeled "問題" when they give an order or an idea to the team. b) ticket seems to be handled as a symbol in non-tech people's mind compare to some workd, which non-tech people already have some image related to. c) as we all agree that redmine is not only for 問題, and redmine already have "tracker" attribute for the type of issue.(I'm in a management position but sure not to be qualified ;-p)

anyway, my 2 cents.

#3 Updated by chris mcharg over 9 years ago

Thanks for the responses Satoru and Yasushi.

To add to what Yasushi said...

1. The word "Issue" is not "Ticket".

I know its important to keep the translation as close to the original as possible, but

  • The word "Issue" is not "Problem"
  • Ticket just works better. It is more encompassing (due to it be an abstract object), and matches the user experience (big yellow ticket)

I guess this would be easier if the English label was changed to ticket first... :)

And I feel that the term "チケット" is not mature,
used mainly among IT early adopters, software development venture companies, and so on.

My feeling would be that チケット is a very easy concept to understand, so there's no need to be conservative about using it.

Also, with the above line of reasoning, how do words like カスタムフィールド, ワークフロー, カスタムクエリ, サマリ, トラッカー stand up?

2. I select the word from general translation of "Issue Tracking(問題管理/課題管理)",
because these words might be acceptable for managers in Japanese company (than "チケット").

I think it would be best to aim for "best fit" for all users rather than worry about what one group might potentially think.

In the end I think that チケット is more congruent with redmine's functionality, so I hope I can get your support for this change Satoru.

Cheers.

#4 Updated by Satoru KURASHIKI over 9 years ago

hi,

I have a consciousness of being in a way paranoid not to change concept of words.
("問題" is not only "problem" but also "issue", and I feel that "ticket" represents "How" to deal with things while "issue" represents "What".)

But anyway, I agree these:

1) we write one issue on a ticket, so it should be ok to use a ticket and an issue interchangeably. (we do that while we are talking, don't we?)

I think it would be best to aim for "best fit" for all users rather than worry about what one group might potentially think.

And I will make consistent with this (#717) patch. It has conflict with my recent update (#693), I will re-attach #693's file.

P.S.
Maybe there are some other Japanese translation which bring discomfort. Any comments?
(for example, "活動" could be better...)
I intend to update ja.yml for a time, then I'm very glad to make use of a tip.

regards,

#5 Updated by chris mcharg over 9 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Thanks very much for that... much appreciated!

Maybe there are some other Japanese translation which bring discomfort. Any comments?
(for example, "活動" could be better...)

Hmm... not to sure, maybe 更新歴? But thats not a directly translation either is it :-)

I intend to update ja.yml for a time, then I'm very glad to make use of a tip.

Will definitely let you know if something grabs my attention.

Thanks again.


Resovled by #693 (ja.yml, 2008-02-28)

#6 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from Resolved to Closed

Committed in r1132.

Also available in: Atom PDF