Feature #7328

Cloning/Duplicating an Issue with subtasks should allow to clone/duplicate the sub-tasks as well

Added by Daniel Reiche almost 9 years ago. Updated over 3 years ago.

Status:ClosedStart date:2011-01-14
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

When a parent issue is cloned/duplicated, the subtasks/children are not processed.

This should be modified, to allow either clone a parent alone, or with all children, leading to a deep clone of the entire issue tree.

Right now, an issue can only be cloned by itself. If, for whatever reason, you want to create a copy of an entire issue tree, you'll have to copy every issue by hand and re-create the parent-child relations in each of cloned issues.


Related issues

Duplicates Redmine - Feature #6965: Option to Copy Subtasks when copying an issue Closed 2010-11-23

History

#1 Updated by Daniel Reiche almost 9 years ago

Sorry, noticed now that there are two issues referring to the same problem: #7023 and #6965
please mark as duplicate of #7023, which has a possible solution attached.
THX

#2 Updated by Go MAEDA over 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Fixed by #6965 (Redmine 2.1.0).

#3 Updated by Go MAEDA over 3 years ago

  • Duplicates Feature #6965: Option to Copy Subtasks when copying an issue added

Also available in: Atom PDF