Feature #7703

In issue filtering view, only allow issue status selections which are available in the current project

Added by Jonathan Betz over 6 years ago. Updated about 2 years ago.

Status:ClosedStart date:2011-02-23
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

Say I have two projects, A and B.

Project A has tracker A1, which has a set of possible issue statuses A1.x, A1.y, A1.z, etc.

Project B has tracker B1, which has a set of possible issue statuses B1.m, B1.n, B1.o, etc.

When I go to the Issues page for project A and try to filter to issues where the status is XXX, the available options for status is the union of all statuses from all trackers. I would expect that the issue filtering for project A would be limited to those statuses which are valid for trackers available in project A.


Related issues

Duplicates Redmine - Defect #5385: Status filter should show statuses related to project tra... Closed 2010-04-26

History

#1 Updated by Go MAEDA about 2 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as duplicate of #5385.

#2 Updated by Go MAEDA about 2 years ago

  • Related to Defect #5385: Status filter should show statuses related to project trackers only added

#3 Updated by Go MAEDA about 2 years ago

  • Related to deleted (Defect #5385: Status filter should show statuses related to project trackers only)

#4 Updated by Go MAEDA about 2 years ago

  • Duplicates Defect #5385: Status filter should show statuses related to project trackers only added

Also available in: Atom PDF